aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-04-10 09:04:38 +0300
committerTimo Teräs <timo.teras@iki.fi>2014-04-10 09:05:32 +0300
commit93584b42f19b9e907c6a652542621ae7ea7b298f (patch)
tree52bdb67bca72a7688a32b36c5f54b981c9127078
parent7f5e784d563fe686f9e1e58a63390840a6c6e203 (diff)
downloadaports-93584b42f19b9e907c6a652542621ae7ea7b298f.tar.bz2
aports-93584b42f19b9e907c6a652542621ae7ea7b298f.tar.xz
main/util-linux: fix hwclock setenv() usage
it's incorrect, and crashes on musl. http://lists.alpinelinux.org/alpine-devel/3638.html
-rw-r--r--main/util-linux/APKBUILD6
-rw-r--r--main/util-linux/fix-setenv-usage.patch12
2 files changed, 17 insertions, 1 deletions
diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index c7f37fc104..0fbc18794a 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -8,7 +8,7 @@ case $pkgver in
*.*) _v=$pkgver;;
esac
-pkgrel=4
+pkgrel=5
pkgdesc="Random collection of Linux utilities"
url="http://kernel.org/~kzak/util-linux/"
arch="all"
@@ -21,6 +21,7 @@ source="http://www.kernel.org/pub/linux/utils/util-linux/v${_v}/util-linux-$pkgv
program-invocation.patch
gentoo-no-scanf.patch
util-linux-posix.patch
+ fix-setenv-usage.patch
ttydefaults.h
"
subpackages="$pkgname-doc $pkgname-dev libuuid libblkid sfdisk cfdisk mcookie blkid"
@@ -126,14 +127,17 @@ md5sums="b39fde897334a4858bb2098edcce5b3f util-linux-2.23.2.tar.xz
9682a6ddd5abe65434a145ebe512c123 program-invocation.patch
da609e7f045bec81e10868fa66d649c6 gentoo-no-scanf.patch
43a03270b6e49fdf4c7fb0ab3390c242 util-linux-posix.patch
+7033d8ec10f6ff52c8120afbe9522490 fix-setenv-usage.patch
6196f1ce853dfaf717569c1e35555d6d ttydefaults.h"
sha256sums="7c4042bd91f621250d7b3b2f34e3b11921a32c7f080c149dcc0c7ce62a8a7cac util-linux-2.23.2.tar.xz
2bfa27969effc77631e981bbbcd1bf261e61f3e51875db950883ddb2a90ea4fd program-invocation.patch
2843a637f8300720b0f0917496d7b814d210a8777c93cfac51fcd3e5777e21d5 gentoo-no-scanf.patch
d099d398d5e6649276d0ccd3b276aa762f52efec8295706370fef44287a2386f util-linux-posix.patch
+ff1625c8d479511b263c1beb86bf6c30c2e13142183647f4fa8c62ff1bc68910 fix-setenv-usage.patch
46faf1198bd884d12c5d45019a5fec8dfdefeae6721d8c9f3da89921acdb2a6d ttydefaults.h"
sha512sums="dcccf8e3a3892a2ac98eea0a7e1c24c1b612ef10b466a8b34d8ebe6c2d49778bc9e8bfb1866ce0daa6db387396659120c290c5b36f47864c4d513b5ed15f9618 util-linux-2.23.2.tar.xz
5a07e86fa84961f73e53677d202e7a2101704eacb698426e62da897af07c7f1227e841f79ff59deed50cfb0e9ef1816f7c3fd03382ae4aa46909b6cd41a95d4e program-invocation.patch
b505f828d64567cf28590de15200e89b4ca26c562134db4c1bb8adf829a903a703d92d3597a5d86d1053ff602c41f84d88cf16b45ef7d857a021c73a9b7d0ee7 gentoo-no-scanf.patch
4a5052caad3a9fb176283d49c486256453ede2a10d99c5f0a4e78a25a03f09a69c6d840756e07aaee581003b018c8b8279e6f727712edf03ff755d162544b729 util-linux-posix.patch
+310acfe2f171010014d25b1788ea64bffc5a315f4fef8d3b8fc9b003bda8810111b12987052eb2d5856500bd6b742792c977608fe9459ce2efe7545ef0054588 fix-setenv-usage.patch
876bb9041eca1b2cca1e9aac898f282db576f7860aba690a95c0ac629d7c5b2cdeccba504dda87ff55c2a10b67165985ce16ca41a0694a267507e1e0cafd46d9 ttydefaults.h"
diff --git a/main/util-linux/fix-setenv-usage.patch b/main/util-linux/fix-setenv-usage.patch
new file mode 100644
index 0000000000..44638d40f5
--- /dev/null
+++ b/main/util-linux/fix-setenv-usage.patch
@@ -0,0 +1,12 @@
+diff -ru util-linux-2.23.2.orig/sys-utils/hwclock.c util-linux-2.23.2/sys-utils/hwclock.c
+--- util-linux-2.23.2.orig/sys-utils/hwclock.c 2013-06-13 10:46:10.000000000 +0300
++++ util-linux-2.23.2/sys-utils/hwclock.c 2014-04-10 09:01:47.931470656 +0300
+@@ -390,7 +390,7 @@
+ * libc's:
+ * TZUTC=:/usr/share/zoneinfo/right/UTC
+ */
+- setenv("TZ", getenv("TZUTC"), TRUE);
++ setenv("TZ", getenv("TZUTC") ?: "", TRUE);
+ /*
+ * Note: tzset() gets called implicitly by the time code,
+ * but only the first time. When changing the environment