aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-04-11 06:44:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-04-11 06:46:51 +0000
commitd9cda70e2c149004f1e87edd1de8f6e332e76953 (patch)
treed0d48b92e84a5ff8c0fd4e336bb886b5d33e5e05
parent108b2efe7608de735507aaef27518a8d2381a530 (diff)
downloadaports-d9cda70e2c149004f1e87edd1de8f6e332e76953.tar.bz2
aports-d9cda70e2c149004f1e87edd1de8f6e332e76953.tar.xz
main/firefox: workaround libGL's initial-exec TLS breakage on musl
https://bugs.freedesktop.org/show_bug.cgi?id=35268
-rw-r--r--main/firefox/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/firefox/APKBUILD b/main/firefox/APKBUILD
index 791b1c96e6..9f1fc1dbfb 100644
--- a/main/firefox/APKBUILD
+++ b/main/firefox/APKBUILD
@@ -4,7 +4,7 @@ pkgname=firefox
pkgver=26.0
_pkgver=$pkgver
_xulver=$pkgver
-pkgrel=4
+pkgrel=5
pkgdesc="firefox web browser"
url="http://www.firefox.com"
arch="all"
@@ -119,10 +119,14 @@ package() {
# launcher as symlink is broken from firefox-7.0
rm "$pkgdir"/usr/bin/firefox || return 1
+ libgl=$(scanelf -qF '#F%S' /usr/lib/libGL.so)
cat > "$pkgdir"/usr/bin/firefox << __EOF__
#!/bin/sh
-exec $_mozappdir/firefox "\$@"
+# as a workaround for libGL's initial-exec TLS we preload libgl
+# https://bugs.freedesktop.org/show_bug.cgi?id=35268
+
+LD_PRELOAD=$libgl exec $_mozappdir/firefox "\$@"
__EOF__
chmod 755 "$pkgdir"/usr/bin/firefox