aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-07-16 13:34:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-07-16 13:34:48 +0000
commit36b1667c368adbc7cb916e6853fe273ac5212422 (patch)
tree768433875a239b03adf4a38cdeaeae7d2f013326
parentfab2ac478af6b2d39a6dfcff3caa2e346f3f82a4 (diff)
downloadaports-36b1667c368adbc7cb916e6853fe273ac5212422.tar.bz2
aports-36b1667c368adbc7cb916e6853fe273ac5212422.tar.xz
testing/sshfs: new aport
FUSE client based on the SSH File Transfer Protocol http://fuse.sourceforge.net/sshfs.html ref #210
-rw-r--r--testing/sshfs/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/sshfs/APKBUILD b/testing/sshfs/APKBUILD
new file mode 100644
index 0000000000..f911831236
--- /dev/null
+++ b/testing/sshfs/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=sshfs
+pkgver=2.2
+pkgrel=0
+pkgdesc="FUSE client based on the SSH File Transfer Protocol"
+url="http://fuse.sourceforge.net/sshfs.html"
+license="GPL"
+depends="openssh-client"
+makedepends="pkgconfig fuse-dev glib-dev"
+source="http://downloads.sourceforge.net/sourceforge/fuse/sshfs-fuse-$pkgver.tar.gz"
+
+_builddir="$srcdir"/sshfs-fuse-$pkgver
+build ()
+{
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="26e9206eb5169e87e6f95f54bc005a4f sshfs-fuse-2.2.tar.gz"