aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-16 07:37:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-16 07:37:17 +0000
commitfc4c60f233ebe9fe85b7b03d0cf5deec4ab1b32d (patch)
treebf9e3dd4f101e4dc917684c9ca67f46e01567374
parent9bc74006681df0fbbc4fd5a4a922cae9b9ea29e2 (diff)
downloadaports-fc4c60f233ebe9fe85b7b03d0cf5deec4ab1b32d.tar.bz2
aports-fc4c60f233ebe9fe85b7b03d0cf5deec4ab1b32d.tar.xz
Makefile: do not require lua pkgconfig unless you intend build lua module
-rw-r--r--src/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/Makefile b/src/Makefile
index 50f9664f19..bea288ee29 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -1,12 +1,9 @@
-PKGDEPS := openssl zlib lua
-
-ifeq ($(shell pkg-config --print-errors --exists $(PKGDEPS) || echo fail),fail)
-$(error Build dependencies are not met)
-endif
+PKGDEPS := openssl zlib
# lua module
ifneq ($(LUAAPK),)
LIBAPK := YesPlease
+PKGDEPS += lua
shlibs-y += apk.so
apk.so-objs := lua-apk.o
CFLAGS_lua-apk.o := -DAPK_VERSION=\"$(FULL_VERSION)\"
@@ -16,6 +13,10 @@ install-LUA_LIB-y := $(INSTALLDIR) $(DESTDIR)$(LUA_LIBDIR) \
$(INSTALL) $(LUA_LIB-y) $(DESTDIR)$(LUA_LIBDIR)
endif
+ifeq ($(shell pkg-config --print-errors --exists $(PKGDEPS) || echo fail),fail)
+$(error Build dependencies are not met)
+endif
+
progs-y += apk
apk-objs := apk.o add.o del.o fix.o update.o info.o \
search.o upgrade.o cache.o ver.o index.o fetch.o \