aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teras <timo.teras@iki.fi>2009-07-29 19:07:14 +0300
committerTimo Teras <timo.teras@iki.fi>2009-07-29 19:07:14 +0300
commit2887e04cd7ea8fcc3e0815a11db6899d1c9535bf (patch)
treec0096f23136d61865fc37616d51eedea700b37c5
parent8cacc96bf034ac40bb702651c939235fe19df824 (diff)
downloadaports-2887e04cd7ea8fcc3e0815a11db6899d1c9535bf.tar.bz2
aports-2887e04cd7ea8fcc3e0815a11db6899d1c9535bf.tar.xz
build: make install depend on main targets
apparently the double colon rule dependencies affect only the specific rule-set.
-rw-r--r--Make.rules3
-rw-r--r--Makefile2
-rw-r--r--src/Makefile2
3 files changed, 3 insertions, 4 deletions
diff --git a/Make.rules b/Make.rules
index aa1a8b3d07..e6db2804f3 100644
--- a/Make.rules
+++ b/Make.rules
@@ -241,8 +241,7 @@ endif
compile: $(targets)
@:
-install:: $(targets) FORCE
- @:
+install: $(targets) FORCE
clean: $(filter %/,$(targets))
ifeq ($(toplevelrun),yes)
diff --git a/Makefile b/Makefile
index 74d997ce3c..08e2585e17 100644
--- a/Makefile
+++ b/Makefile
@@ -29,7 +29,7 @@ include Make.rules
##
# Top-level targets
-install::
+install:
$(INSTALLDIR) $(DESTDIR)$(DOCDIR)
$(INSTALL) README $(DESTDIR)$(DOCDIR)
diff --git a/src/Makefile b/src/Makefile
index 503a7516e8..96e36b358c 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -21,6 +21,6 @@ LIBS := -Wl,--as-needed \
$(shell pkg-config --libs $(PKGDEPS)) \
-Wl,--no-as-needed
-install::
+install:
$(INSTALLDIR) $(DESTDIR)$(SBINDIR)
$(INSTALL) $(obj)/apk $(DESTDIR)$(SBINDIR)