aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-11-05 13:29:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-11-12 09:35:58 +0000
commit69699c8aeaedad4c913c3e580e97d37d670479bd (patch)
tree0981d06233c9f4e71de9d193e3e179f0be9b1549
parent460e66876edbdb2c0da40311bbfa37d846699628 (diff)
downloadaports-69699c8aeaedad4c913c3e580e97d37d670479bd.tar.bz2
aports-69699c8aeaedad4c913c3e580e97d37d670479bd.tar.xz
main/linux-grsec: fix linux-firmware
ref #466 (cherry picked from commit b904fe2aadb86c41592da4a7559e2551e8e428f6)
-rw-r--r--main/linux-grsec/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index c46238b233..e35a10474a 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,11 +4,11 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=2.6.35.8
_kernver=2.6.35
-pkgrel=1
+pkgrel=2
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
-makedepends="perl installkernel"
+makedepends="perl installkernel bash"
options="!strip"
_config=${config:-kernelconfig.${CARCH:-x86}}
install=
@@ -77,7 +77,8 @@ package() {
mkdir -p "$pkgdir"/boot "$pkgdir"/lib/modules
make modules_install firmware_install install \
INSTALL_MOD_PATH="$pkgdir" \
- INSTALL_PATH="$pkgdir"/boot
+ INSTALL_PATH="$pkgdir"/boot \
+ || return 1
rm -f "$pkgdir"/lib/modules/${_abi_release}/build \
"$pkgdir"/lib/modules/${_abi_release}/source