aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-11-22 14:48:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-03 14:43:45 +0000
commit6f00b16899ac54975654379a487643334a61df4a (patch)
treeebe8038efff328f3e11361514c8aeee96a126f37
parent473929523993725b18176f0eb3a825594c92388b (diff)
downloadaports-6f00b16899ac54975654379a487643334a61df4a.tar.bz2
aports-6f00b16899ac54975654379a487643334a61df4a.tar.xz
main/alpine-conf: fix lbu status to handle encrypted apkovl - second try
previous only removed unused patch. This is the real thing ref #480 (cherry picked from commit 0bd949f2206eddafb94f3f63022851b9a355a4b4)
-rw-r--r--main/alpine-conf/0001-lbu-fix-lbu-status-for-encrypted-apkovls.patch46
-rw-r--r--main/alpine-conf/APKBUILD6
2 files changed, 50 insertions, 2 deletions
diff --git a/main/alpine-conf/0001-lbu-fix-lbu-status-for-encrypted-apkovls.patch b/main/alpine-conf/0001-lbu-fix-lbu-status-for-encrypted-apkovls.patch
new file mode 100644
index 0000000000..422a322de4
--- /dev/null
+++ b/main/alpine-conf/0001-lbu-fix-lbu-status-for-encrypted-apkovls.patch
@@ -0,0 +1,46 @@
+From d43136f093e2893457c4e0d944925c97ba86effc Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Mon, 22 Nov 2010 14:42:36 +0000
+Subject: [PATCH] lbu: fix lbu status for encrypted apkovls
+
+http://redmine.alpinelinux.org/issues/480
+---
+ lbu.in | 7 ++++++-
+ 1 files changed, 6 insertions(+), 1 deletions(-)
+
+diff --git a/lbu.in b/lbu.in
+index 527b9e7..309a8ab 100644
+--- a/lbu.in
++++ b/lbu.in
+@@ -140,6 +140,9 @@ unpack_apkovl() {
+ local count=0
+ mkdir -p "$dest"
+ mount_once "$mnt"
++ if [ -n "$ENCRYPTION" ]; then
++ f="$f.$ENCRYPTION"
++ fi
+ if [ ! -f "$mnt/$f" ]; then
+ return 1
+ fi
+@@ -147,7 +150,6 @@ unpack_apkovl() {
+ tar -C "$dest" -zxf "$mnt/$f"
+ return
+ fi
+- f="$f.$ENCRYPTION"
+ check_openssl
+ while [ $count -lt 3 ]; do
+ $OPENSSL enc -d -$ENCRYPTION -in "$mnt/$f" | tar \
+@@ -564,7 +566,10 @@ cmd_status() {
+ unpack_apkovl "$tmp/a"
+
+ # generate new apkovl and extract to tmpdir/b
++ local save_encryption="$ENCRYPTION"
++ ENCRYPTION=
+ cmd_package - | tar -C "$tmp/b" -zx
++ ENCRYPTION="$save_encryption"
+
+ # show files that exists in a but not in b as deleted
+ local f
+--
+1.7.3.2
+
diff --git a/main/alpine-conf/APKBUILD b/main/alpine-conf/APKBUILD
index b2c9e708b9..2db83fdc77 100644
--- a/main/alpine-conf/APKBUILD
+++ b/main/alpine-conf/APKBUILD
@@ -1,11 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-conf
pkgver=2.5.3
-pkgrel=0
+pkgrel=1
pkgdesc="Alpine configuration management scripts"
url=http://git.alpinelinux.org/cgit/$pkgname
depends="openrc"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
+ 0001-lbu-fix-lbu-status-for-encrypted-apkovls.patch
"
license="GPL-2"
@@ -34,4 +35,5 @@ package() {
ln -s lbu "$pkgdir"/sbin/lbu_$i
done
}
-md5sums="d1b94aa7ee65f31693cd1996c6bef4d6 alpine-conf-2.5.3.tar.bz2"
+md5sums="d1b94aa7ee65f31693cd1996c6bef4d6 alpine-conf-2.5.3.tar.bz2
+1ada3c97ecceb791e5f082223f6326b5 0001-lbu-fix-lbu-status-for-encrypted-apkovls.patch"