aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff Bilyk <jbilyk@gmail.com>2011-01-31 22:47:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-04 15:21:38 +0000
commit1cafa9f49c5b7e2bb3dd928a2134bc7dad4ffb4b (patch)
tree567adbfd955933afd048b0258df328b7840b74b7
parente79ee51e816714b1936a6977596d426502d16dea (diff)
downloadaports-1cafa9f49c5b7e2bb3dd928a2134bc7dad4ffb4b.tar.bz2
aports-1cafa9f49c5b7e2bb3dd928a2134bc7dad4ffb4b.tar.xz
main/freeswitch: add rebootstrap.sh call to actually fix libpri
ref #514 (cherry picked from commit b93f7262803d7169a8a9a9a9ba583d67493aaf37)
-rw-r--r--main/freeswitch/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 143cd197d1..b5482236db 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -26,15 +26,17 @@ prepare() {
build() {
cd "$_builddir"
- cp -f "$srcdir/modules.conf" modules.conf || return 1
# i think our max cmd len is 32768
# by specifying it here we save our selves from some CPU cycles
export lt_cv_sys_max_cmd_len=8192
+ ./rebootstrap.sh
+
+ cp -f "$srcdir/modules.conf" modules.conf || return 1
+
# remove -Werror since gcc-4.5 is more strict
sed -i -e 's/-Werror//g' configure || return 1
-
./configure --prefix=/usr \
--sysconfdir=/etc/freeswitch \
--with-modinstdir=/usr/lib/freeswitch \