aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff Bilyk <jbilyk@gmail.com>2011-01-21 23:34:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-04 15:20:50 +0000
commit2ca5f1cfd1a464ac1ad500661b507aa619ce1d74 (patch)
tree45cb7d675922cb78e47f9d09f829fe528861a7b5
parentde1836ca3a4a663efed3190f7b445e44f5748248 (diff)
downloadaports-2ca5f1cfd1a464ac1ad500661b507aa619ce1d74.tar.bz2
aports-2ca5f1cfd1a464ac1ad500661b507aa619ce1d74.tar.xz
main/freeswitch: add support for freetdm and libpri
ref # 514 (cherry picked from commit ad7f39fa0464538e97c3b1e5acf3e61c8fb9f623)
-rw-r--r--main/freeswitch/APKBUILD11
-rw-r--r--main/freeswitch/modules.conf1
2 files changed, 9 insertions, 3 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index a9f3c3e638..9e3658c860 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -2,13 +2,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=freeswitch
pkgver=1.0.6
-pkgrel=14
+pkgrel=15
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
license="GPL"
depends=""
makedepends="curl-dev unixodbc-dev zlib-dev openssl-dev ncurses-dev
- autoconf automake libtool"
+ autoconf automake libtool libpri bash"
install="$pkgname.pre-install $pkgname.post-install $pkgname.pre-upgrade"
subpackages="$pkgname-dev $pkgname-flite $pkgname-sample-config:conf"
source="http://files.freeswitch.org/freeswitch-$pkgver.tar.gz
@@ -19,6 +19,11 @@ source="http://files.freeswitch.org/freeswitch-$pkgver.tar.gz
_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$_builddir"
+ sed -i 's,freetdm.h,../src/include/freetdm.h,' libs/freetdm/mod_freetdm/mod_freetdm.c
+}
+
build() {
cd "$_builddir"
cp -f "$srcdir/modules.conf" modules.conf || return 1
@@ -96,6 +101,6 @@ conf() {
}
md5sums="388effee587887a81fe7f411b7350590 freeswitch-1.0.6.tar.gz
-1f9ed1daf9a1fb910571857c27b933ad modules.conf
+1986cb9499d787b28c8655dd73ebe013 modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
aa358c9ca0d8b93fabb6a36a5ed4c469 freeswitch.initd"
diff --git a/main/freeswitch/modules.conf b/main/freeswitch/modules.conf
index ca3fd9723f..396f018200 100644
--- a/main/freeswitch/modules.conf
+++ b/main/freeswitch/modules.conf
@@ -44,6 +44,7 @@ endpoints/mod_loopback
#endpoints/mod_alsa
#endpoints/mod_opal
#../../libs/openzap/mod_openzap
+../../libs/freetdm/mod_freetdm
#event_handlers/mod_event_multicast
event_handlers/mod_event_socket
event_handlers/mod_cdr_csv