aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-17 08:14:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-17 08:16:53 +0000
commit09b86b364821b9b2ffc81944cc7d4c104666df8c (patch)
tree0f4f66368f8a76dea8643a836653cdb0a013dc26
parent5586efbff3dc884c1cc9546b3e7c7a13727aa43a (diff)
downloadaports-09b86b364821b9b2ffc81944cc7d4c104666df8c.tar.bz2
aports-09b86b364821b9b2ffc81944cc7d4c104666df8c.tar.xz
main/acf-weblog: strip TCP_DENIED from logs
ref #892 (cherry picked from commit 7c45bf94207fd982b32d074845b810cb0c14a371)
-rw-r--r--main/acf-weblog/0001-Do-not-import-TCP_DENIED-lines.patch33
-rw-r--r--main/acf-weblog/APKBUILD18
2 files changed, 48 insertions, 3 deletions
diff --git a/main/acf-weblog/0001-Do-not-import-TCP_DENIED-lines.patch b/main/acf-weblog/0001-Do-not-import-TCP_DENIED-lines.patch
new file mode 100644
index 0000000000..e7f284d3ec
--- /dev/null
+++ b/main/acf-weblog/0001-Do-not-import-TCP_DENIED-lines.patch
@@ -0,0 +1,33 @@
+From 39417cdb0db6b80b6a8fd38e05b77e75d90717b8 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Tue, 20 Dec 2011 14:19:37 +0100
+Subject: [PATCH] Do not import TCP_DENIED lines
+
+Those pages were never showed to the client so there is no point in store
+those for analyzing. Some applications (like Nokia connection suite) will
+ignore an auth reject and will retry several times per second which will
+flood the logs.
+---
+ weblog-model.lua | 6 ++++++
+ 1 files changed, 6 insertions(+), 0 deletions(-)
+
+diff --git a/weblog-model.lua b/weblog-model.lua
+index 07222fd..fe6fc37 100644
+--- a/weblog-model.lua
++++ b/weblog-model.lua
+@@ -652,6 +652,12 @@ local function parsesquidlog(line)
+
+ checkwords(logentry)
+
++ -- Don't care about TCP_DENIED so apps like dropbox, nokia connection
++ -- suite does not flood our logs.
++ if logentry.code == nil or logentry.code == "TCP_DENIED" then
++ return nil
++ end
++
+ -- Don't care about local requests (from DG) (this check also removes blank lines)
+ if logentry.clientip and logentry.clientip ~= "127.0.0.1" then
+ logentry.logdatetime = os.date("%Y-%m-%d %H:%M:%S", logentry.logdatetime)..string.match(logentry.logdatetime, "%..*")
+--
+1.7.8.3
+
diff --git a/main/acf-weblog/APKBUILD b/main/acf-weblog/APKBUILD
index 85925993c4..1cff68ab6c 100644
--- a/main/acf-weblog/APKBUILD
+++ b/main/acf-weblog/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Ted Trask <ttrask01@yahoo.com>
pkgname=acf-weblog
pkgver=0.6.1
-pkgrel=0
+pkgrel=1
pkgdesc="ACF for web proxy (squid and dansguardian) logfiles"
url="http://git.alpinelinux.org/cgit/acf-weblog"
arch="noarch"
@@ -11,11 +11,23 @@ depends="acf-core lua lua-sql-postgres wget postgresql-client"
makedepends=""
install="$pkgname.post-upgrade"
subpackages=""
-source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2"
+source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
+ 0001-Do-not-import-TCP_DENIED-lines.patch
+ "
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
}
-md5sums="9690f8ebdb6e5cb4e67d72ed01f03730 acf-weblog-0.6.1.tar.bz2"
+md5sums="9690f8ebdb6e5cb4e67d72ed01f03730 acf-weblog-0.6.1.tar.bz2
+1235af17a1dc3b787cd6401945aa12f6 0001-Do-not-import-TCP_DENIED-lines.patch"