aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-04 08:00:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-04 10:54:24 +0000
commit444f6067d59a88b5e8d6346099e864efb231606c (patch)
tree532a535e7b0c2ee72a1ea01a3553c9c8b23d7fe0
parent0dbd42c94d6d598b20bf553b733732854b0c173c (diff)
downloadaports-444f6067d59a88b5e8d6346099e864efb231606c.tar.bz2
aports-444f6067d59a88b5e8d6346099e864efb231606c.tar.xz
main/busybox: remove relocated symlinks
(cherry picked from commit b60e57c4f819be22d4691d4a0feff7f2e4931cdd)
-rw-r--r--main/busybox/APKBUILD2
-rw-r--r--main/busybox/busybox.post-upgrade10
2 files changed, 7 insertions, 5 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index fcfb6088c2..e942e696a1 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.19.3
-pkgrel=2
+pkgrel=3
_bbsuidver=0.6
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
diff --git a/main/busybox/busybox.post-upgrade b/main/busybox/busybox.post-upgrade
index c55561cc11..268f22d408 100644
--- a/main/busybox/busybox.post-upgrade
+++ b/main/busybox/busybox.post-upgrade
@@ -1,9 +1,11 @@
#!/bin/sh
-# /bin/install has moved to /usr/bin/install, but we need remove old link
-if [ -L /bin/install ] && [ "$(readlink /bin/install)" = "/bin/busybox" ]; then
- rm /bin/install
-fi
+# remove links that has been relocated
+for link in /bin/install /bin/ip /bin/vi /usr/bin/lspci; do
+ if [ -L "$link" ] && [ "$(readlink $link)" = "/bin/busybox" ]; then
+ rm "$link"
+ fi
+done
# We need the symlinks early
exec /bin/busybox --install -s