aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-26 12:01:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-26 12:01:22 +0000
commit491e887ade12124fdaa0ad0538d03eeeb9143ec2 (patch)
tree124596ed350ea535ce0b5818530c04e4e33c09b9
parentb2637994dcef00cf781d755864c04f0ce6216c6e (diff)
downloadaports-491e887ade12124fdaa0ad0538d03eeeb9143ec2.tar.bz2
aports-491e887ade12124fdaa0ad0538d03eeeb9143ec2.tar.xz
main/xchat: fixes for glib-2.32
-rw-r--r--main/xchat/APKBUILD8
-rw-r--r--main/xchat/link-gmodule.patch11
-rw-r--r--main/xchat/xchat-2.8.8-glib-2.31.patch62
3 files changed, 79 insertions, 2 deletions
diff --git a/main/xchat/APKBUILD b/main/xchat/APKBUILD
index 1dfeb67256..41f8cc37e3 100644
--- a/main/xchat/APKBUILD
+++ b/main/xchat/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xchat
pkgver=2.8.8
-pkgrel=4
+pkgrel=5
pkgdesc="A GTK+ based IRC client"
url="http://www.xchat.org/"
arch="all"
@@ -11,6 +11,8 @@ makedepends="pkgconfig gtk+-dev openssl-dev dbus-glib-dev perl-dev
libxext-dev"
source="http://www.$pkgname.org/files/source/2.8/$pkgname-$pkgver.tar.bz2
midori.patch
+ xchat-2.8.8-glib-2.31.patch
+ link-gmodule.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -45,4 +47,6 @@ package() {
}
md5sums="6775c44f38e84d06c06c336b32c4a452 xchat-2.8.8.tar.bz2
-759fd786be3a2546be33f7533632b5a2 midori.patch"
+759fd786be3a2546be33f7533632b5a2 midori.patch
+98f5c7b49a3e0bad4ef0b7871fdcd8b5 xchat-2.8.8-glib-2.31.patch
+6efe686e4747e1ea22c368cf83fb6ea2 link-gmodule.patch"
diff --git a/main/xchat/link-gmodule.patch b/main/xchat/link-gmodule.patch
new file mode 100644
index 0000000000..fbc1a50060
--- /dev/null
+++ b/main/xchat/link-gmodule.patch
@@ -0,0 +1,11 @@
+--- ./src/fe-gtk/Makefile.in.orig
++++ ./src/fe-gtk/Makefile.in
+@@ -150,7 +150,7 @@
+ GTK_CFLAGS = @GTK_CFLAGS@
+ GTK_LIBS = @GTK_LIBS@
+ GUI_CFLAGS = @GUI_CFLAGS@
+-GUI_LIBS = @GUI_LIBS@
++GUI_LIBS = @GUI_LIBS@ -lgmodule-2.0
+ HAVE_ASPRINTF = @HAVE_ASPRINTF@
+ HAVE_POSIX_PRINTF = @HAVE_POSIX_PRINTF@
+ HAVE_SNPRINTF = @HAVE_SNPRINTF@
diff --git a/main/xchat/xchat-2.8.8-glib-2.31.patch b/main/xchat/xchat-2.8.8-glib-2.31.patch
new file mode 100644
index 0000000000..63f562ff83
--- /dev/null
+++ b/main/xchat/xchat-2.8.8-glib-2.31.patch
@@ -0,0 +1,62 @@
+Author: Dominique Leuenberger <dimstar@opensuse.org>
+
+http://sourceforge.net/tracker/?func=detail&aid=3446968&group_id=239&atid=100239
+
+glib got stricter in checking includes. Only glib.h (and a few exceptions)
+are to be included directly.
+
+Index: xchat-2.8.8/src/common/servlist.c
+===================================================================
+--- xchat-2.8.8.orig/src/common/servlist.c
++++ xchat-2.8.8/src/common/servlist.c
+@@ -24,7 +24,7 @@
+ #include <unistd.h>
+
+ #include "xchat.h"
+-#include <glib/ghash.h>
++#include <glib.h>
+
+ #include "cfgfiles.h"
+ #include "fe.h"
+Index: xchat-2.8.8/src/common/text.c
+===================================================================
+--- xchat-2.8.8.orig/src/common/text.c
++++ xchat-2.8.8/src/common/text.c
+@@ -28,7 +28,7 @@
+ #include <sys/mman.h>
+
+ #include "xchat.h"
+-#include <glib/ghash.h>
++#include <glib.h>
+ #include "cfgfiles.h"
+ #include "chanopt.h"
+ #include "plugin.h"
+Index: xchat-2.8.8/src/common/util.c
+===================================================================
+--- xchat-2.8.8.orig/src/common/util.c
++++ xchat-2.8.8/src/common/util.c
+@@ -39,7 +39,7 @@
+ #include <errno.h>
+ #include "xchat.h"
+ #include "xchatc.h"
+-#include <glib/gmarkup.h>
++#include <glib.h>
+ #include <ctype.h>
+ #include "util.h"
+ #include "../../config.h"
+Index: xchat-2.8.8/src/common/xchat.h
+===================================================================
+--- xchat-2.8.8.orig/src/common/xchat.h
++++ xchat-2.8.8/src/common/xchat.h
+@@ -1,10 +1,6 @@
+ #include "../../config.h"
+
+-#include <glib/gslist.h>
+-#include <glib/glist.h>
+-#include <glib/gutils.h>
+-#include <glib/giochannel.h>
+-#include <glib/gstrfuncs.h>
++#include <glib.h>
+ #include <time.h> /* need time_t */
+
+ #ifndef XCHAT_H