aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-26 16:04:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-26 16:04:52 +0000
commit6a3dd6b3632b7e44e71ec9be2ba10bad49e2b9c8 (patch)
tree6bd06d5097230501b18b149597c55a291f1d8ec6
parent07abe2e0f46ff69f55ae7bcdb1aa28661e684726 (diff)
downloadaports-6a3dd6b3632b7e44e71ec9be2ba10bad49e2b9c8.tar.bz2
aports-6a3dd6b3632b7e44e71ec9be2ba10bad49e2b9c8.tar.xz
main/gnome-control-center: split out -lang and gmodule link fix
-rw-r--r--main/gnome-control-center/APKBUILD10
-rw-r--r--main/gnome-control-center/link-gmodule.patch26
2 files changed, 32 insertions, 4 deletions
diff --git a/main/gnome-control-center/APKBUILD b/main/gnome-control-center/APKBUILD
index 3ebe306a68..c7c1417cad 100644
--- a/main/gnome-control-center/APKBUILD
+++ b/main/gnome-control-center/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=gnome-control-center
pkgver=2.32.1
-pkgrel=4
+pkgrel=5
pkgdesc="GNOME configuration applets"
url="http://www.gnome.org"
arch="all"
@@ -34,8 +34,9 @@ depends_dev="gtk+-dev
libxklavier-dev"
makedepends="$depends_dev intltool gobject-introspection-dev desktop-file-utils"
install="$pkgname.post-install $pkgname.pre-deinstall $pkgname.post-upgrade"
-subpackages=
-source="ftp://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
+subpackages="$pkgname-lang"
+source="ftp://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
+ link-gmodule.patch"
_builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
@@ -66,4 +67,5 @@ package() {
find "$pkgdir" -name '*.la' -delete
}
-md5sums="b4e8ab5c7556ae07addbfcfb4fa2f761 gnome-control-center-2.32.1.tar.bz2"
+md5sums="b4e8ab5c7556ae07addbfcfb4fa2f761 gnome-control-center-2.32.1.tar.bz2
+ccbfe3d954cc7d0bb91ef081a51793ea link-gmodule.patch"
diff --git a/main/gnome-control-center/link-gmodule.patch b/main/gnome-control-center/link-gmodule.patch
new file mode 100644
index 0000000000..9bf14ec961
--- /dev/null
+++ b/main/gnome-control-center/link-gmodule.patch
@@ -0,0 +1,26 @@
+diff --git a/capplets/appearance/Makefile.in b/capplets/appearance/Makefile.in
+index 4b8df30..9c62c4f 100644
+--- a/capplets/appearance/Makefile.in
++++ b/capplets/appearance/Makefile.in
+@@ -386,7 +386,7 @@ gnome_appearance_properties_LDADD = \
+ $(top_builddir)/capplets/common/libcommon.la \
+ $(GNOMECC_CAPPLETS_LIBS) \
+ $(FONT_CAPPLET_LIBS) \
+- $(METACITY_LIBS)
++ $(METACITY_LIBS) -lgmodule-2.0
+
+ gnome_appearance_properties_LDFLAGS = -export-dynamic
+ gtkbuilderdir = $(pkgdatadir)/ui
+diff --git a/capplets/common/Makefile.in b/capplets/common/Makefile.in
+index 00e594a..5f1849a 100644
+--- a/capplets/common/Makefile.in
++++ b/capplets/common/Makefile.in
+@@ -365,7 +365,7 @@ gnome_theme_test_SOURCES = \
+
+ gnome_theme_test_LDADD = \
+ libcommon.la \
+- $(GNOMECC_CAPPLETS_LIBS)
++ $(GNOMECC_CAPPLETS_LIBS) -lgmodule-2.0
+
+ all: all-am
+