aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-26 16:32:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-26 16:32:32 +0000
commitd602a03a62afbbaf8843ac79c02ab83527fe66de (patch)
tree8238636d0581c44f67814d8a27be6a54fb435589
parentfc885d9b34d4913eb3bff0b0b108bca1a508bcf5 (diff)
downloadaports-d602a03a62afbbaf8843ac79c02ab83527fe66de.tar.bz2
aports-d602a03a62afbbaf8843ac79c02ab83527fe66de.tar.xz
main/gnome-panel: gmodule link
-rw-r--r--main/gnome-panel/APKBUILD9
-rw-r--r--main/gnome-panel/link-gmodule.patch22
2 files changed, 28 insertions, 3 deletions
diff --git a/main/gnome-panel/APKBUILD b/main/gnome-panel/APKBUILD
index c367154248..6e3ce26bde 100644
--- a/main/gnome-panel/APKBUILD
+++ b/main/gnome-panel/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=gnome-panel
pkgver=2.32.1
-pkgrel=11
+pkgrel=12
pkgdesc="GNOME Panel"
url="http://projects.gnome.org/gnome-panel"
arch="all"
@@ -24,7 +24,9 @@ subpackages="$pkgname-dev $pkgname-lang"
replaces_dev="$pkgname"
source="ftp://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
as-needed.patch
- libm-underlinking.patch"
+ libm-underlinking.patch
+ link-gmodule.patch
+ "
_builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
@@ -55,4 +57,5 @@ package() {
md5sums="a228035e1f7026abf296b797f1f7d2f9 gnome-panel-2.32.1.tar.bz2
42a7f2693e5f99ce3440bd53ebccbae0 as-needed.patch
-292372a7f264bb63ca9eb3c69a664ee1 libm-underlinking.patch"
+292372a7f264bb63ca9eb3c69a664ee1 libm-underlinking.patch
+399b61956a678c60e0f0d28eeca63aba link-gmodule.patch"
diff --git a/main/gnome-panel/link-gmodule.patch b/main/gnome-panel/link-gmodule.patch
new file mode 100644
index 0000000000..a92791fa49
--- /dev/null
+++ b/main/gnome-panel/link-gmodule.patch
@@ -0,0 +1,22 @@
+diff --git a/gnome-panel/Makefile.in b/gnome-panel/Makefile.in
+index d2b72bb..27e624c 100644
+--- a/gnome-panel/Makefile.in
++++ b/gnome-panel/Makefile.in
+@@ -582,7 +582,7 @@ gnome_panel_LDADD = \
+ $(top_builddir)/gnome-panel/libpanel-util/libpanel-util.la \
+ $(PANEL_LIBS) \
+ $(XRANDR_LIBS) \
+- $(X_LIBS) -lm
++ $(X_LIBS) -lm -lgmodule-2.0
+
+ gnome_panel_LDFLAGS = -export-dynamic
+ gnome_desktop_item_edit_SOURCES = \
+@@ -612,7 +612,7 @@ panel_test_applets_CPPFLAGS = \
+ panel_test_applets_LDADD = \
+ $(top_builddir)/gnome-panel/libpanel-applet-private/libpanel-applet-private-mini.la \
+ $(top_builddir)/gnome-panel/libpanel-util/libpanel-util.la \
+- $(PANEL_LIBS)
++ $(PANEL_LIBS) -lgmodule-2.0
+
+ panel_test_applets_LDFLAGS = -export-dynamic
+ panel_enum_headers = \