aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-26 10:03:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-26 10:03:50 +0000
commite2c73b39f5d8235ef6ac14bf4bb66d1b39ec2657 (patch)
tree0b37c87b394f16a8587d541694ff990251f9ef17
parentabbc54b57d137e56bde8b434fa97caf5ed20db50 (diff)
downloadaports-e2c73b39f5d8235ef6ac14bf4bb66d1b39ec2657.tar.bz2
aports-e2c73b39f5d8235ef6ac14bf4bb66d1b39ec2657.tar.xz
main/gtk+2.0: fix libgtk-x11 dso
-rw-r--r--main/gtk+2.0/APKBUILD26
-rw-r--r--main/gtk+2.0/gtk2-fixdso.patch15
-rw-r--r--main/gtk+2.0/xid-collision-debug.patch15
3 files changed, 53 insertions, 3 deletions
diff --git a/main/gtk+2.0/APKBUILD b/main/gtk+2.0/APKBUILD
index 61df5894f0..03c815acd4 100644
--- a/main/gtk+2.0/APKBUILD
+++ b/main/gtk+2.0/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gtk+2.0
pkgver=2.24.10
-pkgrel=1
+pkgrel=2
pkgdesc="The GTK+ Toolkit (v2)"
url="http://www.gtk.org/"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
@@ -25,12 +25,14 @@ depends_dev="
pango-dev
"
makedepends="pkgconfig
+ autoconf automake libtool
$depends_dev
cups-dev
expat-dev
gettext-dev
gnutls-dev
gobject-introspection-dev
+ gtk-doc
libice-dev
libiconv-dev
jpeg-dev>=8
@@ -43,10 +45,24 @@ makedepends="pkgconfig
libxi-dev
tiff-dev
zlib-dev"
-source="http://ftp.gnome.org/pub/gnome/sources/gtk+/${pkgver%.*}/gtk+-$pkgver.tar.xz"
+source="http://ftp.gnome.org/pub/gnome/sources/gtk+/${pkgver%.*}/gtk+-$pkgver.tar.xz
+ xid-collision-debug.patch
+ gtk2-fixdso.patch
+ "
_builddir="$srcdir"/gtk+-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ libtoolize && autoreconf
+}
+
build() {
cd "$_builddir"
./configure --prefix=/usr \
@@ -55,6 +71,8 @@ build() {
--with-xinput=yes \
--without-libjasper \
--with-included-loaders=png || return 1
+ # https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool || return 1
make || return 1
}
@@ -74,4 +92,6 @@ dev() {
"$subpkgdir"/usr/bin || return 1
}
-md5sums="7fdcb407dd174010a695b555bf9b65e2 gtk+-2.24.10.tar.xz"
+md5sums="7fdcb407dd174010a695b555bf9b65e2 gtk+-2.24.10.tar.xz
+22355df723f6ca358e30e6b8f0baace5 xid-collision-debug.patch
+b1f61a42b2fa3c54eb2e0d6c130a0f0a gtk2-fixdso.patch"
diff --git a/main/gtk+2.0/gtk2-fixdso.patch b/main/gtk+2.0/gtk2-fixdso.patch
new file mode 100644
index 0000000000..3ea784699e
--- /dev/null
+++ b/main/gtk+2.0/gtk2-fixdso.patch
@@ -0,0 +1,15 @@
+--- gtk+-2.24.8/gtk/Makefile.am.orig 2012-02-01 11:14:25.468115547 +0000
++++ gtk+-2.24.8/gtk/Makefile.am 2012-02-01 11:14:57.920116650 +0000
+@@ -904,10 +904,10 @@
+ libgtk_quartz_2_0_la_SOURCES = $(gtk_c_sources)
+ libgtk_directfb_2_0_la_SOURCES = $(gtk_c_sources)
+
+-libgtk_x11_2_0_la_LDFLAGS = $(libtool_opts)
++libgtk_x11_2_0_la_LDFLAGS = $(libtool_opts) -lgmodule-2.0
+ libgtk_win32_2_0_la_LDFLAGS = $(libtool_opts) -Wl,-luuid
+ libgtk_quartz_2_0_la_LDFLAGS = $(libtool_opts)
+-libgtk_directfb_2_0_la_LDFLAGS = $(libtool_opts)
++libgtk_directfb_2_0_la_LDFLAGS = $(libtool_opts) -lgmodule-2.0
+
+ libgtk_x11_2_0_la_LIBADD = $(libadd)
+ libgtk_win32_2_0_la_LIBADD = $(libadd) -lole32 -lgdi32 -lcomdlg32 -lwinspool -lcomctl32
diff --git a/main/gtk+2.0/xid-collision-debug.patch b/main/gtk+2.0/xid-collision-debug.patch
new file mode 100644
index 0000000000..d61238c3b2
--- /dev/null
+++ b/main/gtk+2.0/xid-collision-debug.patch
@@ -0,0 +1,15 @@
+--- gtk+-2.18.3/gdk/x11/gdkxid.c 2009-06-19 04:59:18.000000000 +0200
++++ gtk+-2.18.3/gdk/x11/gdkxid.c.new 2009-07-22 11:30:12.000000000 +0200
+@@ -56,10 +56,10 @@
+ if (!display_x11->xid_ht)
+ display_x11->xid_ht = g_hash_table_new ((GHashFunc) gdk_xid_hash,
+ (GEqualFunc) gdk_xid_equal);
+-
++/*
+ if (g_hash_table_lookup (display_x11->xid_ht, xid))
+ g_warning ("XID collision, trouble ahead");
+-
++*/
+ g_hash_table_insert (display_x11->xid_ht, xid, data);
+ }
+