aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-01-10 15:14:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-01-10 15:14:47 +0000
commit922f711ba6a57adf2802bc6de93f791081ee31cd (patch)
tree683677be00bceb6de26764a6a22a58524c096c69
parent2bbf957009d807dc147e917ced91aab0661141f9 (diff)
downloadaports-922f711ba6a57adf2802bc6de93f791081ee31cd.tar.bz2
aports-922f711ba6a57adf2802bc6de93f791081ee31cd.tar.xz
main/linux-grsec: fix for rx_missed on r8169 driver
Some info in this thread: http://marc.info/?l=linux-netdev&m=135763417428530&w=2
-rw-r--r--main/linux-grsec/APKBUILD4
-rw-r--r--main/linux-grsec/r8169-num-rx-desc.patch13
2 files changed, 16 insertions, 1 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 543d513280..ee50cd19b9 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=3.4.24
_kernver=3.4
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -19,6 +19,7 @@ source="http://ftp.kernel.org/pub/linux/kernel/v3.x/linux-$_kernver.tar.xz
0004-arp-flush-arp-cache-on-device-change.patch
0001-Revert-ipv4-Don-t-use-the-cached-pmtu-informations-f.patch
intel_idle.patch
+ r8169-num-rx-desc.patch
kernelconfig.x86
kernelconfig.x86_64
@@ -146,5 +147,6 @@ f23a2fcf6562f3219e43385c787cff23 grsecurity-2.9.1-3.4.24-0.patch
776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
cb6fcd6e966e73c87a839c4c0183f81f 0001-Revert-ipv4-Don-t-use-the-cached-pmtu-informations-f.patch
d2f7ba780ff7567c21381428264d7fdd intel_idle.patch
+daf2cbb558588c49c138fe9ca2482b64 r8169-num-rx-desc.patch
50a13359236dbd676fa355f0b4fd27ff kernelconfig.x86
c402f52babc729d1280c1677075aa0d7 kernelconfig.x86_64"
diff --git a/main/linux-grsec/r8169-num-rx-desc.patch b/main/linux-grsec/r8169-num-rx-desc.patch
new file mode 100644
index 0000000000..c50d963ff9
--- /dev/null
+++ b/main/linux-grsec/r8169-num-rx-desc.patch
@@ -0,0 +1,13 @@
+diff --git a/drivers/net/ethernet/realtek/r8169.c b/drivers/net/ethernet/realtek/r8169.c
+index 9cc0215..19e5b4d 100644
+--- a/drivers/net/ethernet/realtek/r8169.c
++++ b/drivers/net/ethernet/realtek/r8169.c
+@@ -80,7 +80,7 @@ static const int multicast_filter_limit = 32;
+ #define R8169_REGS_SIZE 256
+ #define R8169_NAPI_WEIGHT 64
+ #define NUM_TX_DESC 64 /* Number of Tx descriptor registers */
+-#define NUM_RX_DESC 256 /* Number of Rx descriptor registers */
++#define NUM_RX_DESC 512 /* Number of Rx descriptor registers */
+ #define RX_BUF_SIZE 1536 /* Rx Buffer size */
+ #define R8169_TX_RING_BYTES (NUM_TX_DESC * sizeof(struct TxDesc))
+ #define R8169_RX_RING_BYTES (NUM_RX_DESC * sizeof(struct RxDesc))