aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2012-10-30 21:06:16 +0200
committerTimo Teräs <timo.teras@iki.fi>2012-10-30 21:06:16 +0200
commit88fd20aa7ac87089becdc3d4f53f6ce6f5c399e6 (patch)
tree8f1e6029ac8df615db96721adb131c7bae04284e
parent18835ee93c20eedd30fdc14fe9ceeba8a0c34d96 (diff)
downloadaports-88fd20aa7ac87089becdc3d4f53f6ce6f5c399e6.tar.bz2
aports-88fd20aa7ac87089becdc3d4f53f6ce6f5c399e6.tar.xz
testing/asterisk: upgrade to 11.0.0
* add ASTERISK-20527 from main/asterisk
-rw-r--r--testing/asterisk/APKBUILD6
-rw-r--r--testing/asterisk/ASTERISK-20527.patch26
2 files changed, 30 insertions, 2 deletions
diff --git a/testing/asterisk/APKBUILD b/testing/asterisk/APKBUILD
index 60d27a4dcd..1a5f0e5d3e 100644
--- a/testing/asterisk/APKBUILD
+++ b/testing/asterisk/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Timo Teras <timo.teras@iki.fi>
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=asterisk
-pkgver=11.0.0_rc1
+pkgver=11.0.0
pkgrel=0
pkgdesc="Asterisk: A Module Open Source PBX System"
pkgusers="asterisk"
@@ -24,6 +24,7 @@ source="http://downloads.asterisk.org/pub/telephony/asterisk/releases/asterisk-$
101-caps-uclibc.patch
ASTERISK-18995.patch
ASTERISK-19109.patch
+ ASTERISK-20527.patch
asterisk.initd
asterisk.confd
asterisk.logrotate"
@@ -180,11 +181,12 @@ sound_en() {
chown -R asterisk:asterisk "$subpkgdir"/var/*/asterisk
}
-md5sums="43aa79170adae2d8d36d811f8a23f69c asterisk-11.0.0-rc1.tar.gz
+md5sums="e23c8535a425253764bdddeee49d1778 asterisk-11.0.0.tar.gz
b00c9d98ce2ad445501248a197c6e436 100-uclibc-daemon.patch
6e1129e30c4fd2c25c86c81685a485a9 101-caps-uclibc.patch
bc6713f5434e07b79d3afdd155461d72 ASTERISK-18995.patch
146befabe95798a67c58d8ac00d397a6 ASTERISK-19109.patch
+676ca42ee1859d8a7bae4345ede5eb89 ASTERISK-20527.patch
74cd25a5638a94ef51e9f4ede2fd28f2 asterisk.initd
ed31d7ba37bcf8b0346dcf8593c395f0 asterisk.confd
3e65172275684373e1a25c8a11224411 asterisk.logrotate"
diff --git a/testing/asterisk/ASTERISK-20527.patch b/testing/asterisk/ASTERISK-20527.patch
new file mode 100644
index 0000000000..42a81d8ca5
--- /dev/null
+++ b/testing/asterisk/ASTERISK-20527.patch
@@ -0,0 +1,26 @@
+diff --git a/channels/chan_sip.c b/channels/chan_sip.c
+index 7569bba..24a8cec 100644
+--- a/channels/chan_sip.c
++++ b/channels/chan_sip.c
+@@ -30189,7 +30189,7 @@ static struct sip_peer *build_peer(const char *name, struct ast_variable *v, str
+ olddirectmediaacl = ast_free_acl_list(olddirectmediaacl);
+ if (!ast_strlen_zero(peer->callback)) { /* build string from peer info */
+ char *reg_string;
+- if (ast_asprintf(&reg_string, "%s?%s:%s@%s/%s", peer->name, peer->username, !ast_strlen_zero(peer->remotesecret) ? peer->remotesecret : peer->secret, peer->tohost, peer->callback) >= 0) {
++ if (ast_asprintf(&reg_string, "%s?%s:%s:%s@%s/%s", peer->name, S_OR(peer->fromuser, peer->username), S_OR(peer->remotesecret, peer->secret), peer->username, peer->tohost, peer->callback) >= 0) {
+ sip_register(reg_string, 0); /* XXX TODO: count in registry_count */
+ ast_free(reg_string);
+ }
+diff --git a/configs/sip.conf.sample b/configs/sip.conf.sample
+index 81ca998..812be7b 100644
+--- a/configs/sip.conf.sample
++++ b/configs/sip.conf.sample
+@@ -711,7 +711,7 @@ srvlookup=yes ; Enable DNS SRV lookups on outbound calls
+ ; A similar effect can be achieved by adding a "callbackextension" option in a peer section.
+ ; this is equivalent to having the following line in the general section:
+ ;
+-; register => username:secret@host/callbackextension
++; register => fromuser:secret:username@host/callbackextension
+ ;
+ ; and more readable because you don't have to write the parameters in two places
+ ; (note that the "port" is ignored - this is a bug that should be fixed).