aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-10-30 15:47:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-10-30 15:48:12 +0000
commitfdc263f1fb2b78d7bbe234de7b7761bec6ea4435 (patch)
tree223206a7feb907f0e07516e49a7ba9454b02b825
parent7af044db75df9a7bc07c56b34c422909f5559aef (diff)
downloadaports-fdc263f1fb2b78d7bbe234de7b7761bec6ea4435.tar.bz2
aports-fdc263f1fb2b78d7bbe234de7b7761bec6ea4435.tar.xz
main/pangox-compat: new aport
Compatibility lib for pangox http://pango.org
-rw-r--r--main/pangox-compat/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/pangox-compat/APKBUILD b/main/pangox-compat/APKBUILD
new file mode 100644
index 0000000000..4d55baf932
--- /dev/null
+++ b/main/pangox-compat/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=pangox-compat
+pkgver=0.0.2
+pkgrel=0
+pkgdesc="Compatibility lib for pangox"
+url="http://pango.org"
+arch="all"
+license="LGPL"
+depends=""
+depends_dev="pango-dev libice-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://ftp.gnome.org/pub/gnome/sources/pangox-compat/${pkgver%.*}/pangox-compat-$pkgver.tar.xz"
+
+_builddir="$srcdir"/pangox-compat-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="7bcbd0187f03e1e27af9a81e07249c33 pangox-compat-0.0.2.tar.xz"