aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2012-01-02 09:48:38 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2012-01-02 09:48:38 +0000
commitdaafae5c7c194f4d3ba052691a043da06c294a46 (patch)
treea8765c2f2a060f6f9fc70e14527615442e609e5e
parentda37ecbd7f19f180768ec2abb8b2359eac218b9a (diff)
parente3af3051a27a999981c041adbf68692b93029c75 (diff)
downloadaports-daafae5c7c194f4d3ba052691a043da06c294a46.tar.bz2
aports-daafae5c7c194f4d3ba052691a043da06c294a46.tar.xz
Merge git://dev.alpinelinux.org/aports
-rw-r--r--main/galculator/APKBUILD25
-rw-r--r--main/galculator/galculator-1.3.4-libm.patch11
-rw-r--r--main/libssh/APKBUILD8
-rw-r--r--main/libssh/link-pthread.patch63
4 files changed, 98 insertions, 9 deletions
diff --git a/main/galculator/APKBUILD b/main/galculator/APKBUILD
index 1bfff07d46..529559c1bb 100644
--- a/main/galculator/APKBUILD
+++ b/main/galculator/APKBUILD
@@ -1,18 +1,30 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=galculator
pkgver=1.3.4
-pkgrel=2
+pkgrel=3
pkgdesc="GTK+ based scientific calculator"
url="http://galculator.sourceforge.net/"
arch="all"
license="GPL"
depends=
-makedepends="intltool libglade-dev gtk+-dev"
-subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2"
+makedepends="intltool libglade-dev gtk+-dev autoconf automake libtool flex bison"
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2
+ galculator-1.3.4-libm.patch"
+
+_builddir="$srcdir/galculator-$pkgver"
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ libtoolize --force && aclocal && autoconf && automake --add-missing
+}
build() {
- cd "$srcdir/galculator-$pkgver"
+ cd "$_builddir"
./configure --prefix=/usr || return 1
make || return 1
}
@@ -21,4 +33,5 @@ package() {
cd "$srcdir/galculator-$pkgver"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="d30e6fbf5947bb1c873bc9d5a21046f1 galculator-1.3.4.tar.bz2"
+md5sums="d30e6fbf5947bb1c873bc9d5a21046f1 galculator-1.3.4.tar.bz2
+467de62f8737c800eb1db93e501de3cb galculator-1.3.4-libm.patch"
diff --git a/main/galculator/galculator-1.3.4-libm.patch b/main/galculator/galculator-1.3.4-libm.patch
new file mode 100644
index 0000000000..e7472fe83c
--- /dev/null
+++ b/main/galculator/galculator-1.3.4-libm.patch
@@ -0,0 +1,11 @@
+diff -up galculator-1.3.4/configure.in.libm galculator-1.3.4/configure.in
+--- galculator-1.3.4/configure.in.libm 2010-02-16 11:22:31.000000000 +0100
++++ galculator-1.3.4/configure.in 2010-02-16 11:22:12.000000000 +0100
+@@ -11,6 +11,7 @@ AC_PROG_INTLTOOL(, no-xml)
+ AC_ISC_POSIX
+
+ AC_HEADER_STDC
++AC_CHECK_LIB([m],[tan])
+
+ pkg_modules="gtk+-2.0 >= 2.6.0 libglade-2.0 >= 2.0.0"
+ PKG_CHECK_MODULES(PACKAGE, [$pkg_modules])
diff --git a/main/libssh/APKBUILD b/main/libssh/APKBUILD
index 8f15a4e98f..20d86171b7 100644
--- a/main/libssh/APKBUILD
+++ b/main/libssh/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libssh
pkgver=0.5.2
-pkgrel=0
+pkgrel=1
pkgdesc="Library for accessing ssh client services through C libraries"
url="http://www.libssh.org/"
arch="all"
@@ -10,7 +10,8 @@ license="LGPL"
depends=
makedepends="openssl-dev cmake doxygen"
subpackages="$pkgname-dev"
-source="http://www.libssh.org/files/${pkgver%.*}/${pkgname}-${pkgver}.tar.gz"
+source="http://www.libssh.org/files/${pkgver%.*}/${pkgname}-${pkgver}.tar.gz
+ link-pthread.patch"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -41,4 +42,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="38b67c48af7a9204660a3e08f97ceba6 libssh-0.5.2.tar.gz"
+md5sums="38b67c48af7a9204660a3e08f97ceba6 libssh-0.5.2.tar.gz
+8d58b3391286de4dad3eb8a5b70171aa link-pthread.patch"
diff --git a/main/libssh/link-pthread.patch b/main/libssh/link-pthread.patch
new file mode 100644
index 0000000000..2e2c770f6a
--- /dev/null
+++ b/main/libssh/link-pthread.patch
@@ -0,0 +1,63 @@
+diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
+index aeff201..0191d5d 100644
+--- a/examples/CMakeLists.txt
++++ b/examples/CMakeLists.txt
+@@ -13,36 +13,36 @@ include_directories(
+
+ if (LINUX)
+ add_executable(libssh_scp libssh_scp.c ${examples_SRCS})
+- target_link_libraries(libssh_scp ${LIBSSH_SHARED_LIBRARY})
++ target_link_libraries(libssh_scp ${LIBSSH_SHARED_LIBRARY} pthread)
+
+ add_executable(scp_download scp_download.c ${examples_SRCS})
+- target_link_libraries(scp_download ${LIBSSH_SHARED_LIBRARY})
++ target_link_libraries(scp_download ${LIBSSH_SHARED_LIBRARY} pthread)
+
+ add_executable(samplessh sample.c ${examples_SRCS})
+- target_link_libraries(samplessh ${LIBSSH_SHARED_LIBRARY})
++ target_link_libraries(samplessh ${LIBSSH_SHARED_LIBRARY} pthread)
+
+ add_executable(sshnetcat sshnetcat.c ${examples_SRCS})
+- target_link_libraries(sshnetcat ${LIBSSH_SHARED_LIBRARY})
++ target_link_libraries(sshnetcat ${LIBSSH_SHARED_LIBRARY} pthread)
+
+ if (WITH_SFTP)
+ add_executable(samplesftp samplesftp.c ${examples_SRCS})
+- target_link_libraries(samplesftp ${LIBSSH_SHARED_LIBRARY})
++ target_link_libraries(samplesftp ${LIBSSH_SHARED_LIBRARY} pthread)
+ endif (WITH_SFTP)
+
+ if (WITH_SERVER)
+ add_executable(samplesshd samplesshd.c)
+- target_link_libraries(samplesshd ${LIBSSH_SHARED_LIBRARY})
++ target_link_libraries(samplesshd ${LIBSSH_SHARED_LIBRARY} pthread)
+ endif (WITH_SERVER)
+ endif (LINUX)
+
+ add_executable(exec exec.c ${examples_SRCS})
+-target_link_libraries(exec ${LIBSSH_SHARED_LIBRARY})
++target_link_libraries(exec ${LIBSSH_SHARED_LIBRARY} pthread)
+
+ add_executable(senddata senddata.c ${examples_SRCS})
+-target_link_libraries(senddata ${LIBSSH_SHARED_LIBRARY})
++target_link_libraries(senddata ${LIBSSH_SHARED_LIBRARY} pthread)
+
+ add_executable(libsshpp libsshpp.cpp)
+-target_link_libraries(libsshpp ${LIBSSH_SHARED_LIBRARY})
++target_link_libraries(libsshpp ${LIBSSH_SHARED_LIBRARY} pthread)
+
+ add_executable(libsshpp_noexcept libsshpp_noexcept.cpp)
+-target_link_libraries(libsshpp_noexcept ${LIBSSH_SHARED_LIBRARY})
++target_link_libraries(libsshpp_noexcept ${LIBSSH_SHARED_LIBRARY} pthread)
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index e158665..ef2005d 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -40,6 +40,7 @@ if (HAVE_LIBSOCKET)
+ set(LIBSSH_LINK_LIBRARIES
+ ${LIBSSH_LINK_LIBRARIES}
+ socket
++ pthread
+ )
+ endif (HAVE_LIBSOCKET)
+