aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-06-10 15:57:45 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-06-11 12:14:41 +0200
commit73423fc182035ac70d194ddbe2ad01ebff989484 (patch)
tree25b3e186df3f65807c52802f9d2a765fe8a24037
parent12c71704d063ce68bf19b05722c981272df1ec3c (diff)
downloadaports-73423fc182035ac70d194ddbe2ad01ebff989484.tar.bz2
aports-73423fc182035ac70d194ddbe2ad01ebff989484.tar.xz
test: run test*.sh with set -x
-rw-r--r--test/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/Makefile b/test/Makefile
index eefa382d9e..9f43249d4b 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -39,7 +39,7 @@ repos.stamp: $(repos)
@echo -n "$<"; \
rm -rf "$(testroot)" ;\
mkdir -p "$(testroot)"; \
- if ! APK="$(APK)" ROOT="$(testroot)" SYSREPO="$(SYSREPO)" ./$< > $(basename $@).out 2>&1; then\
+ if ! APK="$(APK)" ROOT="$(testroot)" SYSREPO="$(SYSREPO)" sh -ex ./$< > $(basename $@).out 2>&1; then\
echo " FAIL";\
printf "------------- output -------------\n" >&2;\
cat $(basename $@).out >&2;\