aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-10-20 15:09:29 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-10-20 15:09:29 +0200
commit7a8cb236932700d144b1a0aa78a5dd177291b906 (patch)
treedb95fcb72ba49c6188415cbd5fd53e3f2152424c
parentefbaba474005ce307583be223a57d92e6475348b (diff)
downloadaports-7a8cb236932700d144b1a0aa78a5dd177291b906.tar.bz2
aports-7a8cb236932700d144b1a0aa78a5dd177291b906.tar.xz
testing/evolution: moved from unmaintained and upgraded to 3.22.1
-rw-r--r--testing/evolution/APKBUILD50
-rw-r--r--testing/evolution/evolution-3.22.1-inline-images-reply.patch26
-rw-r--r--unmaintained/evolution/APKBUILD53
3 files changed, 76 insertions, 53 deletions
diff --git a/testing/evolution/APKBUILD b/testing/evolution/APKBUILD
new file mode 100644
index 0000000000..93dd25cf27
--- /dev/null
+++ b/testing/evolution/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=evolution
+pkgver=3.22.1
+pkgrel=0
+pkgdesc="evolution mail client"
+url="http://projects.gnome.org/evolution"
+arch="all"
+license="GPL"
+depends="highlight"
+depends_dev="itstool libxml2-dev gcr-dev enchant-dev libcanberra-dev
+ libgweather-dev openldap-dev libnotify-dev"
+makedepends="$depends_dev gperf flex bison libxml2-utils glib-dev
+ webkit2gtk-dev gtkspell3-dev evolution-data-server-dev glib-dev
+ gtk+3.0-dev nss-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://ftp.gnome.org/pub/gnome/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz
+ evolution-3.22.1-inline-images-reply.patch"
+
+builddir="${srcdir}/${pkgname}-${pkgver}"
+
+build() {
+ cd "$builddir"
+ export ac_cv_libiconv_utf8=yes
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-gnome-desktop \
+ --disable-autoar \
+ --disable-libcryptui \
+ --disable-schemas-compile \
+ --disable-pst-import \
+ --with-openldap \
+ --enable-nss=yes \
+ --enable-smime=yes \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="828493ae3eefeb0594ef816fbab9c617 evolution-3.22.1.tar.xz
+c89e344b70aabbe54587589a35d766cf evolution-3.22.1-inline-images-reply.patch"
+sha256sums="fa652d830f4185c33666770e6e9cfcc39d5e2f09486bbd63a084f3527064e52e evolution-3.22.1.tar.xz
+9ec3c72c4d7e8a6bf2a041d409b32f98a6234c1919119718993350070f806459 evolution-3.22.1-inline-images-reply.patch"
+sha512sums="7306605160fd39999ec8c710f65f4cdadd18b19e5b354748e896d0f3a381fc387b7c6017407db69acb681f67e944d15459d31bf9bd392e7c6071610e0be6d1b9 evolution-3.22.1.tar.xz
+d9ea821ff0e9e570fd39a2edda36fe28aa4544766423120297639f43e5115b6ff7409e5d959fc396303c81cfc31abae90c903821861ec57309c8294eb571e314 evolution-3.22.1-inline-images-reply.patch"
diff --git a/testing/evolution/evolution-3.22.1-inline-images-reply.patch b/testing/evolution/evolution-3.22.1-inline-images-reply.patch
new file mode 100644
index 0000000000..c24148779f
--- /dev/null
+++ b/testing/evolution/evolution-3.22.1-inline-images-reply.patch
@@ -0,0 +1,26 @@
+From d74c18bcc12f056d98cc1fcdb90f4372015ebf0e Mon Sep 17 00:00:00 2001
+From: Milan Crha <mcrha@redhat.com>
+Date: Thu, 13 Oct 2016 13:00:36 +0200
+Subject: [PATCH] Bug 772803 - Inline images cause busy loop on Reply in
+ WebKitWebProcess
+
+---
+ src/modules/webkit-editor/web-extension/e-editor-dom-functions.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/modules/webkit-editor/web-extension/e-editor-dom-functions.c b/modules/webkit-editor/web-extension/e-editor-dom-functions.c
+index c61d365..0e8da0d 100644
+--- a/modules/webkit-editor/web-extension/e-editor-dom-functions.c
++++ b/modules/webkit-editor/web-extension/e-editor-dom-functions.c
+@@ -8419,7 +8419,7 @@ change_cid_images_src_to_base64 (EEditorPage *editor_page)
+
+ list = webkit_dom_document_query_selector_all (
+ document, selector, NULL);
+- for (jj = webkit_dom_node_list_get_length (list) - 1; jj--;) {
++ for (jj = webkit_dom_node_list_get_length (list); jj--;) {
+ WebKitDOMNode *node = webkit_dom_node_list_item (list, jj);
+
+ set_base64_to_element_attribute (
+--
+2.7.4
+
diff --git a/unmaintained/evolution/APKBUILD b/unmaintained/evolution/APKBUILD
deleted file mode 100644
index 4217d01490..0000000000
--- a/unmaintained/evolution/APKBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
-# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=evolution
-pkgver=3.18.4
-pkgrel=1
-pkgdesc="evolution mail client"
-url="http://projects.gnome.org/evolution"
-arch="all"
-license="GPL"
-depends="gnome-icon-theme gsettings-desktop-schemas highlight"
-depends_dev="gtk+3.0-dev glib-dev itstool libxml2-dev libxml2-utils
- webkitgtk-dev gcr-dev evolution-data-server-dev enchant-dev
- libcanberra-dev gtkspell-dev libgweather-dev openldap-dev
- libnotify-dev"
-makedepends="$depends_dev gperf flex bison"
-install=""
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://ftp.gnome.org/pub/gnome/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz"
-
-_builddir="${srcdir}/${pkgname}-${pkgver}"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ac_cv_libiconv_utf8=yes\
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --disable-pst-import \
- --disable-gnome-desktop \
- --disable-autoar \
- --disable-libcryptui \
- --disable-gtkspell \
- --with-openldap \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
-}
-
-md5sums="9262300694650517046b48fb2ae98d30 evolution-3.18.4.tar.xz"
-sha256sums="8161a0ebc77e61904dfaca9745595fefbf84d834a07ee1132d1f8d030dabfefb evolution-3.18.4.tar.xz"
-sha512sums="ddb7922cedd490808c21a21d6a2e23f7399f1569bea69d5e0434f27b0f5b75b898ff68f17883bfd75eddb2ec9059628406e1b1f7811e1962a6da2dff4777ade2 evolution-3.18.4.tar.xz"