aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-07-13 14:29:45 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-07-13 14:29:47 +0000
commitce76efcd7e1fa3532fcda97beae80abfc2e6dc89 (patch)
treefe4e8c9d46cf08c481cec50a7de74db7b227b42a
parentb3de9c7809bc3117b5a183a06c463e3edfbfa80a (diff)
downloadaports-ce76efcd7e1fa3532fcda97beae80abfc2e6dc89.tar.bz2
aports-ce76efcd7e1fa3532fcda97beae80abfc2e6dc89.tar.xz
main/util-linux: support cross building
-rw-r--r--main/util-linux/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index d6f0b4fe1f..4589720948 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -16,7 +16,9 @@ arch="all"
license="GPL2 GPL2+ LGPL2+ BSD Public Domain"
depends="findmnt"
# use GNU sed til bb sed is fixed. Also GNU tar is needed
-makedepends="zlib-dev sed ncurses-dev tar autoconf automake libtool python-dev linux-headers"
+makedepends_build="sed tar autoconf automake libtool"
+makedepends_host="zlib-dev ncurses-dev linux-headers"
+makedepends="$makedepends_build $makedepends_host"
install=
options="suid"
source="http://www.kernel.org/pub/linux/utils/$pkgname/v${_v}/$pkgname-$pkgver.tar.xz
@@ -25,7 +27,11 @@ source="http://www.kernel.org/pub/linux/utils/$pkgname/v${_v}/$pkgname-$pkgver.t
"
subpackages="$pkgname-doc $pkgname-dev $pkgname-bash-completion:bashcomp
libuuid libblkid libmount libsmartcols libfdisk sfdisk cfdisk
- findmnt:_findmnt mcookie blkid py-libmount:_py"
+ findmnt:_findmnt mcookie blkid"
+if [ -z "$BOOTSTRAP" ]; then
+ makedepends_host="$makedepends_host ncurses-dev python-dev"
+ subpackages="$subpackages py-libmount:_py"
+fi
replaces="e2fsprogs util-linux-ng"
_builddir="$srcdir/$pkgname-$pkgver"
@@ -51,16 +57,15 @@ build() {
--host=$CHOST \
--prefix=/usr \
--enable-raw \
+ --with-ncurses \
--disable-uuidd \
--disable-nls \
--disable-tls \
--disable-kill \
- --with-ncurses \
--disable-login \
--disable-last \
--disable-sulogin \
--disable-su \
- --enable-chsh \
|| return 1
make || return 1
}