aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-12-27 11:22:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-12-27 11:56:59 +0000
commite2093c247af4ab0f119b2ffae5902905476bf19e (patch)
tree2186065a870fae23035fda695ff8052141543242
parent71806c0bf1b5ea6b577cc7634d0038a5d0c1fab0 (diff)
downloadaports-e2093c247af4ab0f119b2ffae5902905476bf19e.tar.bz2
aports-e2093c247af4ab0f119b2ffae5902905476bf19e.tar.xz
main/devicemaster-linux-vanilla: upgrade to 4.28 and kernel 4.19.12
-rw-r--r--main/devicemaster-linux-vanilla/APKBUILD12
-rw-r--r--main/devicemaster-linux-vanilla/linux-4.19.patch42
2 files changed, 49 insertions, 5 deletions
diff --git a/main/devicemaster-linux-vanilla/APKBUILD b/main/devicemaster-linux-vanilla/APKBUILD
index 6fa02fa06a..3010b716c3 100644
--- a/main/devicemaster-linux-vanilla/APKBUILD
+++ b/main/devicemaster-linux-vanilla/APKBUILD
@@ -2,12 +2,12 @@
# when changing _ver we *must* bump _rel
_name=devicemaster-linux
-_ver=7.26
+_ver=7.28
_rel=0
_flavor=${FLAVOR:-vanilla}
_kpkg=linux-$_flavor
-_kver=4.14.89
+_kver=4.19.12
_krel=0
_kpkgver="$_kver-r$_krel"
@@ -24,8 +24,9 @@ license="GPL-2.0"
depends="$_kpkg=$_kpkgver"
makedepends="$_kpkg-dev=$_kpkgver linux-headers"
install_if="$_kpkg=$_kpkgver $_name"
-#provides="${_name}-grsec=${pkgver}-r${pkgrel}"
-source="https://dev.alpinelinux.org/archive/devicemaster-linux/devicemaster-linux-$_ver.tar.gz"
+# http://downloads.comtrol.com/html/DM_PRO_RTS_SERIALHUB_drivers.htm
+source="https://dev.alpinelinux.org/archive/devicemaster-linux/devicemaster-linux-$_ver.tar.gz
+ linux-4.19.patch"
builddir="$srcdir"/$_name-$_ver
# grsec legacy
@@ -56,4 +57,5 @@ package() {
cp *.ko "$pkgdir/lib/modules/$_kabi/misc/"
}
-sha512sums="5ae164645824018b99e8e8917d81f336fdef5745cb43fb93582c4e61f58a5c005202c19fcc8b13a4a24f4fc94287bf11f496b447db62bbf67b07da5793a9d8f7 devicemaster-linux-7.26.tar.gz"
+sha512sums="67ca762076e075bb8d0bf9fefbc47df92c4c53018c79977fb575ff6eaeed1d4e97b32b90adf456ec1b3aa301f4a01744f9723232e447ca578afe10192599c9ca devicemaster-linux-7.28.tar.gz
+cb551088201f6405bfc7f4dbdcf815dca03aab9c08ab4b78d3fb4bfff6027d11590db937ec4aaf98a3ab732c4922a1bd09e3e0f4e092d4ffce7b6a6ecdf49e8c linux-4.19.patch"
diff --git a/main/devicemaster-linux-vanilla/linux-4.19.patch b/main/devicemaster-linux-vanilla/linux-4.19.patch
new file mode 100644
index 0000000000..7a7b2545a0
--- /dev/null
+++ b/main/devicemaster-linux-vanilla/linux-4.19.patch
@@ -0,0 +1,42 @@
+diff --git a/nslink.c b/nslink.c
+index 7be65ff..5c7444f 100755
+--- a/nslink.c
++++ b/nslink.c
+@@ -4635,7 +4635,7 @@ static int tcp_txqueue_wait(tTcpTxQueueWait *in)
+ #if LINUX_VERSION_CODE < VERSION_CODE(3,15,0)
+ static void tcp_data_ready(struct sock *sk, int count)
+ #else
+-static void tcp_data_ready(struct sock *sk)
++void tcp_data_ready(struct sock *sk)
+ #endif
+ {
+ struct si_state *si = (struct si_state *)(sk->sk_user_data);
+@@ -5351,19 +5351,6 @@ static int nrp_proc_show(struct seq_file *m, void *v)
+ return 0;
+ }
+
+-static int nrp_proc_open(struct inode *inode, struct file *file)
+-{
+- return single_open(file, nrp_proc_show, NULL);
+-}
+-
+-static const struct file_operations nrp_proc_fops = {
+- .owner = THIS_MODULE,
+- .open = nrp_proc_open,
+- .read = seq_read,
+- .llseek = seq_lseek,
+- .release = single_release,
+-};
+-
+ static struct tty_operations nslink_ops = {
+ .open = nrp_open,
+ .close = nrp_close,
+@@ -5384,7 +5371,7 @@ static struct tty_operations nslink_ops = {
+ .wait_until_sent = nrp_wait_until_sent,
+ .tiocmget = nrp_tiocmget,
+ .tiocmset = nrp_tiocmset,
+- .proc_fops = &nrp_proc_fops,
++ .proc_show = &nrp_proc_show,
+ };
+ static const struct tty_port_operations nslink_port_ops = {
+ .carrier_raised = nrp_port_carrier_raised,