aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-02-27 23:30:15 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2019-02-28 07:15:08 +0000
commitff2dbd7e2b9aeb75317fead3e1ddd086ecde71e9 (patch)
tree98d5dba42c579207e7569f155147b906c9e8f551
parent8c9bc3ab93115dd9c3193f7bd0598d00329fa74d (diff)
downloadaports-ff2dbd7e2b9aeb75317fead3e1ddd086ecde71e9.tar.bz2
aports-ff2dbd7e2b9aeb75317fead3e1ddd086ecde71e9.tar.xz
testing/iwd: new aport
Internet Wireless Daemon
-rw-r--r--testing/iwd/APKBUILD51
-rw-r--r--testing/iwd/iwd.initd13
2 files changed, 64 insertions, 0 deletions
diff --git a/testing/iwd/APKBUILD b/testing/iwd/APKBUILD
new file mode 100644
index 0000000000..5910c0a931
--- /dev/null
+++ b/testing/iwd/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=iwd
+pkgver=0.14
+pkgrel=0
+pkgdesc="Internet Wireless Daemon"
+url="https://iwd.wiki.kernel.org/"
+arch="all"
+license="LGPL-2.1-or-later"
+depends=""
+makedepends="ell-dev dbus-dev readline-dev"
+install=""
+subpackages="$pkgname-openrc"
+source="https://mirrors.edge.kernel.org/pub/linux/network/wireless/$pkgname-${pkgver}.tar.gz
+ iwd.initd
+ "
+builddir="$srcdir/$pkgname-${pkgver}"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-external-ell \
+ --disable-systemd-service \
+ --enable-sim-hardcoded \
+ --enable-tools \
+ --enable-docs
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -m750 -d "$pkgdir"/var/lib/$pkgname
+ install -Dm644 doc/main.conf "$pkgdir"/etc/"$pkgname"/main.conf
+ install -m755 -D "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname
+}
+
+sha512sums="aa4586611d6c7298f9b00fe1de88b83157f037e76c7f01d8c3df8e21d7d6796ce3551be9764681a412bf147e741ff65469adaa6da4d96bdc4e2667059202b656 iwd-0.14.tar.gz
+1a913fa19a76a18d92b8f44cb5b4b99a64b4e2f7d2b4a486bf1ba2f939aea7dcca772fca91483011ada58aaa3addc29c76ececd708b2187e57f72aa040ac77e6 iwd.initd"
diff --git a/testing/iwd/iwd.initd b/testing/iwd/iwd.initd
new file mode 100644
index 0000000000..3ae8fc436a
--- /dev/null
+++ b/testing/iwd/iwd.initd
@@ -0,0 +1,13 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+pidfile="/run/iwd.pid"
+command="/usr/libexec/iwd"
+command_background="yes"
+
+depend() {
+ need dbus
+ before net
+ keyword -shutdown
+}