aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-16 23:59:16 +0300
committerprspkt <prspkt@protonmail.com>2019-06-17 02:07:21 +0300
commit33ee483f9818d87678ae7b7370b86d683fb90308 (patch)
treeb1d94eaa6bac46a33cd82806c1189891547e460a
parent6e2d0889332dc8eec0d3f20ac872029f5ace66bd (diff)
downloadaports-33ee483f9818d87678ae7b7370b86d683fb90308.tar.bz2
aports-33ee483f9818d87678ae7b7370b86d683fb90308.tar.xz
testing/py-w3lib: upgrade to python3
-rw-r--r--testing/py3-w3lib/APKBUILD (renamed from testing/py-w3lib/APKBUILD)13
1 files changed, 8 insertions, 5 deletions
diff --git a/testing/py-w3lib/APKBUILD b/testing/py3-w3lib/APKBUILD
index ab882f5cb9..7195698e1f 100644
--- a/testing/py-w3lib/APKBUILD
+++ b/testing/py3-w3lib/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-w3lib
+pkgname=py3-w3lib
_pkgname=w3lib
pkgver=1.15.0
pkgrel=0
@@ -8,23 +8,26 @@ pkgdesc="A library of web-related functions"
url="https://github.com/scrapy/w3lib"
arch="noarch"
license="BSD"
-depends="python2"
+depends="python3"
depends_dev=""
-makedepends="python2-dev py-setuptools"
+makedepends="py3-setuptools"
install=""
subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-w3lib" # Backwards compatibility
+provides="py-w3lib=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
cd "$builddir"
- python2 setup.py build
+ python3 setup.py build
}
package() {
cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="debf3aed14f423eb36d730802cf23a393ec9364bd91d158b9a78a8e6deeb23886dea62a8cd47ab120b080c3b82c19aa6fc2865fdeb33add45a45389dbbfae5fa w3lib-1.15.0.tar.gz"