aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-09-24 21:53:02 +0200
committerMilan P. Stanić <mps@arvanta.net>2019-09-24 22:00:55 +0200
commit4bd74f059f0f1329481cde93c3aedac1a90f76e6 (patch)
tree9d400dd65c8747b571e904637507bb5f187e58b3
parentdcbab5a0af6934621e5ea40391800dfcb7844c12 (diff)
downloadaports-4bd74f059f0f1329481cde93c3aedac1a90f76e6.tar.bz2
aports-4bd74f059f0f1329481cde93c3aedac1a90f76e6.tar.xz
community/glm: upgrade to 0.9.9.6
remove fix-const-expr.patch, fixed upstream fix CRLF to LF in fix-endian-test.patch use 'cp' in package(), upstream removed 'make install' add pkgconfig glm.pc from previous version, upstream removed it add -doc subpackage fix source url
-rw-r--r--community/glm/APKBUILD26
-rw-r--r--community/glm/fix-const-expr.patch10
-rw-r--r--community/glm/fix-endian-test.patch46
-rw-r--r--community/glm/glm.pc7
4 files changed, 45 insertions, 44 deletions
diff --git a/community/glm/APKBUILD b/community/glm/APKBUILD
index 738bf0e154..f68acca3b0 100644
--- a/community/glm/APKBUILD
+++ b/community/glm/APKBUILD
@@ -1,18 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=glm
-pkgver=0.9.9.3
-pkgrel=2
+pkgver=0.9.9.6
+pkgrel=0
pkgdesc="C++ mathematics library for graphics programming"
url="http://glm.g-truc.net/"
arch="noarch"
license="MIT"
makedepends="cmake"
-subpackages="$pkgname-dev"
-source="https://github.com/g-truc/glm/releases/download/$pkgver/glm-$pkgver.zip
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/g-truc/glm/archive/$pkgver.tar.gz
fix-endian-test.patch
- fix-const-expr.patch
+ glm.pc
"
-builddir="$srcdir/$pkgname"
+builddir="$srcdir/$pkgname-$pkgver"
patch_args="--binary -p1"
build() {
@@ -33,10 +33,14 @@ check() {
}
package() {
- cd "$builddir"/build
- make install DESTDIR="$pkgdir"
+ mkdir -p "$pkgdir"/usr/include/
+ cp -r glm "$pkgdir"/usr/include/
+ mkdir -p "$pkgdir"/usr/share/doc
+ cp -r doc "$pkgdir"/usr/share/doc/glm
+ mkdir -p "$pkgdir"/usr/lib/pkgconfig
+ cp ../glm.pc "$pkgdir"/usr/lib/pkgconfig/
}
-sha512sums="eb7589345eb627d9fda84771bd2cf3eb0e4e9e48bf6bb7490bd8844b66558717de5dc96cde9d66e81f7ba4e54090f18dbe1bbccb2452ed0ed8c17cdf7b6e4aa2 glm-0.9.9.3.zip
-54fd8926e3e8271ea32ff25b433003e7eef5611ac7b3c397c0e3b5cd6b139071dba774964c8ae4f8859523a354fec45e38d4ad8fdd46f930f21ce529cc95a65e fix-endian-test.patch
-ef0d6cafbc684f0451b21de82f758480929531dbbce557ace9c9e53f9af65493fe85e1c080f5575efd8da8f0a86dae0cbb0605264d6d58eef1d27db6a6d96e8a fix-const-expr.patch"
+sha512sums="1bc8fc1da21e19f95d4a24259993c7932db328fdd2d0db68dbf60c07f372e19003a8df094fb4e153bb7f50df584c17cf0a540d3d3c38b7a287f3b55314ec2d70 glm-0.9.9.6.tar.gz
+93e02285b7530bb5fdad71905a55150e64cda3d036f43fca166eddb2e8d2f2d03025543c96dfd44234a37f860ea0682be2c683a66c9d4ef33f5bc269c95bbdfa fix-endian-test.patch
+185a9eae06b4bd291c72351239a969e37b83feb1b2de64c397f657370aff81241bf489f0109c74d50cd7106389c2740b0f620f39cdd3604dc51ed9b5046442af glm.pc"
diff --git a/community/glm/fix-const-expr.patch b/community/glm/fix-const-expr.patch
deleted file mode 100644
index c977036983..0000000000
--- a/community/glm/fix-const-expr.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/glm/detail/setup.hpp
-+++ b/glm/detail/setup.hpp
-@@ -283,7 +283,6 @@
- #else
- # define GLM_HAS_CONSTEXPR ((GLM_LANG & GLM_LANG_CXX0X_FLAG) && GLM_HAS_INITIALIZER_LISTS && (\
- ((GLM_COMPILER & GLM_COMPILER_INTEL) && (GLM_COMPILER >= GLM_COMPILER_INTEL17)) || \
-- ((GLM_COMPILER & GLM_COMPILER_GCC) && (GLM_COMPILER >= GLM_COMPILER_GCC6)) || \
- ((GLM_COMPILER & GLM_COMPILER_VC) && (GLM_COMPILER >= GLM_COMPILER_VC15))))
- #endif
-
diff --git a/community/glm/fix-endian-test.patch b/community/glm/fix-endian-test.patch
index 7ae44dc96c..ba2cce4b68 100644
--- a/community/glm/fix-endian-test.patch
+++ b/community/glm/fix-endian-test.patch
@@ -3,28 +3,28 @@ index 5830999..86167c5 100644
--- a/test/gtc/gtc_packing.cpp
+++ b/test/gtc/gtc_packing.cpp
@@ -5,6 +5,8 @@
- #include <cstdio>
- #include <vector>
-
-+#include <endian.h>
-+
- void print_bits(float const& s)
- {
- union
+ #include <cstdio>
+ #include <vector>
+
++#include <endian.h>
++
+ void print_bits(float const& s)
+ {
+ union
@@ -154,6 +156,7 @@ int test_U3x10_1x2()
- Error += glm::all(glm::equal(v0, v1)) ? 0 : 1;
- }
-
-+#if BYTE_ORDER == LITTLE_ENDIAN
- glm::u8vec4 const v0(0xff, 0x77, 0x0, 0x33);
- glm::uint32 const p0 = *reinterpret_cast<glm::uint32 const*>(&v0[0]);
- glm::uint32 const r0 = 0x330077ff;
+ Error += glm::all(glm::equal(v0, v1)) ? 0 : 1;
+ }
+
++#if BYTE_ORDER == LITTLE_ENDIAN
+ glm::u8vec4 const v0(0xff, 0x77, 0x0, 0x33);
+ glm::uint32 const p0 = *reinterpret_cast<glm::uint32 const*>(&v0[0]);
+ glm::uint32 const r0 = 0x330077ff;
@@ -165,7 +168,7 @@ int test_U3x10_1x2()
- glm::uint32 const r1 = 0xc001dcff;
-
- Error += p1 == r1 ? 0 : 1;
--
-+#endif
- return Error;
- }
-
+ glm::uint32 const r1 = 0xc001dcff;
+
+ Error += p1 == r1 ? 0 : 1;
+-
++#endif
+ return Error;
+ }
+
diff --git a/community/glm/glm.pc b/community/glm/glm.pc
new file mode 100644
index 0000000000..e3bb5acc1a
--- /dev/null
+++ b/community/glm/glm.pc
@@ -0,0 +1,7 @@
+prefix=/usr
+includedir=${prefix}/include
+
+Name: GLM
+Description: OpenGL Mathematics
+Version: 0.9.9
+Cflags: -I${includedir}