aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Isaksen <d@duniel.no>2017-09-23 21:23:46 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-09-27 05:31:07 +0000
commit674c89f70139703f1b5b0f767c0bdd40c217416e (patch)
tree4952dd83474d1cc5ce839d448bde423eee8c7b4e
parent902e3528d4f54aa933e676ea45879a3981d769b8 (diff)
downloadaports-674c89f70139703f1b5b0f767c0bdd40c217416e.tar.bz2
aports-674c89f70139703f1b5b0f767c0bdd40c217416e.tar.xz
main/python2: bump to 2.7.14
[TT: reset pkgrel, modernize]
-rw-r--r--main/python2/APKBUILD29
1 files changed, 11 insertions, 18 deletions
diff --git a/main/python2/APKBUILD b/main/python2/APKBUILD
index 854abb7e28..beed74bae6 100644
--- a/main/python2/APKBUILD
+++ b/main/python2/APKBUILD
@@ -2,9 +2,9 @@
pkgname=python2
# the python2-tkinter's pkgver needs to be synchronized with this.
-pkgver=2.7.13
+pkgver=2.7.14
_verbase=${pkgver%.*}
-pkgrel=2
+pkgrel=0
pkgdesc="A high-level scripting language"
url="http://www.python.org"
arch="all"
@@ -21,10 +21,10 @@ source="http://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz
builddir="$srcdir/Python-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
# Make sure we use system libs
- rm -r Modules/expat Modules/_ctypes/libffi* Modules/zlib || return 1
+ rm -r Modules/expat Modules/_ctypes/libffi* Modules/zlib
# make sure our /dev/shm is world writeable
if ! touch /dev/shm/$pkgname-$pkgver; then
@@ -47,26 +47,25 @@ build() {
--with-system-ffi \
--with-system-expat \
--with-system-zlib \
- --enable-unicode=ucs4 \
- || return 1
- make || return 1
+ --enable-unicode=ucs4
+ make
}
package() {
cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ make -j1 DESTDIR="$pkgdir" install
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- rm "$pkgdir/usr/bin/2to3" || return 1
+ rm "$pkgdir/usr/bin/2to3"
# we need to enable emutramp - needed for virt-manager
# disable mprotect - needed for cffi
- paxmark -zm "$pkgdir"/usr/bin/python$_verbase || return 1
+ paxmark -zm "$pkgdir"/usr/bin/python$_verbase
}
_mv_files() {
local i
for i in "$@"; do
mkdir -p "$subpkgdir"/${i%/*}
- mv "$pkgdir"/$i "$subpkgdir"/$i || return 1
+ mv "$pkgdir"/$i "$subpkgdir"/$i
done
}
@@ -100,12 +99,6 @@ gdbm() {
_mv_files $(find usr/lib -name '*gdbm*')
}
-md5sums="53b43534153bb2a0363f08bae8b9d990 Python-2.7.13.tar.xz
-2840477c6552a0ca2f4ede885ad872f1 musl-find_library.patch
-dada786a50fa332686a9b9260d84c110 unchecked-ioctl.patch"
-sha256sums="35d543986882f78261f97787fd3e06274bfa6df29fac9b4a94f73930ff98f731 Python-2.7.13.tar.xz
-83fd071bc556d4e88373a35fde74cb9c464ee4b8e95e5583b55f2e36d4f33cf2 musl-find_library.patch
-f9d37609bab83d9ffff96ec9a33e16568cfb14980d389f7fe34a1c837397e359 unchecked-ioctl.patch"
-sha512sums="f37c9a28ce129d01e63c84d7db627a06402854578f62d17927334ea21ede318e04bbf66e890e3f47c85333e6b19f6e5581fb3f3e27efd24be27017d1b6529c4b Python-2.7.13.tar.xz
+sha512sums="78310b0be6388ffa15f29a80afb9ab3c03a572cb094e9da00cfe391afadb51696e41f592eb658d6a31a2f422fdac8a55214a382cbb8cfb43d4a127d5b35ea7f9 Python-2.7.14.tar.xz
ab8eaa2858d5109049b1f9f553198d40e0ef8d78211ad6455f7b491af525bffb16738fed60fc84e960c4889568d25753b9e4a1494834fea48291b33f07000ec2 musl-find_library.patch
5a8e013a4132d71c4360771f130d27b37275ae59330cf9a75378dc8a11236017f540eb224f2a148984e82ca3fb6b29129375b1080ba05b81044faa717520ab82 unchecked-ioctl.patch"