aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-21 01:39:13 +0200
committerprspkt <prspkt@protonmail.com>2019-03-21 02:04:06 +0200
commit6b78f2fc7e7c2fa9aa5734a2d9d304b87ba93783 (patch)
tree82c360ad4203632c8b74cbfa265f7dcbb4f7c376
parent74d64852a9fe8e06c23e900f5af0f3704d864e55 (diff)
downloadaports-6b78f2fc7e7c2fa9aa5734a2d9d304b87ba93783.tar.bz2
aports-6b78f2fc7e7c2fa9aa5734a2d9d304b87ba93783.tar.xz
community/setconf: switch to pypi
- Add python3-dev and py3-setuptools makedepends. - Generate and package python byte-code.
-rw-r--r--community/setconf/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/community/setconf/APKBUILD b/community/setconf/APKBUILD
index 62826dc032..343bb21c7f 100644
--- a/community/setconf/APKBUILD
+++ b/community/setconf/APKBUILD
@@ -7,14 +7,20 @@ url="http://setconf.roboticoverlords.org/"
arch="noarch"
license="GPL-2.0"
depends="python3"
+makedepends="python3-dev py3-setuptools"
subpackages="$pkgname-doc"
-source="http://setconf.roboticoverlords.org/$pkgname-$pkgver.tar.xz"
+source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
package() {
cd "$builddir"
- install -Dm755 "$pkgname.py" "$pkgdir/usr/bin/$pkgname" || return 1
- install -Dm644 "$pkgname.1.gz" "$pkgdir/usr/share/man/man1/$pkgname.1.gz" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ install -Dm644 "$pkgname.1" "$pkgdir/usr/share/man/man1/$pkgname.1"
}
-sha512sums="eed6e18a9ee279abaa3fa8fd15d9b869d16f84d27a5fcd7e2445e8370e769cb36ab3962aae3d132ca334d0fe640cfae31b22385aa13096d55a545c9ef1823370 setconf-0.7.6.tar.xz"
+sha512sums="46f63e5b5659a53ab7e756cd879f49a371adcbf18a3e9d4fed902b4eba5ca398e4b64206e43e97fdb422d3ad3f3b0b8c1b4ace5931cbefab10f95fe28f8baf80 setconf-0.7.6.tar.gz"