aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2019-01-16 15:16:10 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-01-16 15:18:32 +0000
commit74ad9f86d5cc7f6acf321b7f3c76e790ac458167 (patch)
treead3e49df4198a57e5ef8a2ddfe3ef3e2052dd3a9
parent002c7297a5764dcdbc73e852992ccab400923a53 (diff)
downloadaports-74ad9f86d5cc7f6acf321b7f3c76e790ac458167.tar.bz2
aports-74ad9f86d5cc7f6acf321b7f3c76e790ac458167.tar.xz
testing/py-inflection: new aport
-rw-r--r--testing/py-inflection/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/py-inflection/APKBUILD b/testing/py-inflection/APKBUILD
new file mode 100644
index 0000000000..74ee2fc168
--- /dev/null
+++ b/testing/py-inflection/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py-inflection
+pkgver=0.3.1
+pkgrel=0
+pkgdesc="A port of Ruby on Rails' inflector to Python"
+url="https://github.com/jpvanhal/inflection"
+arch="noarch"
+license="MIT"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools"
+checkdepends=""
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+options="!check" # no test suite
+source="$pkgname-$pkgver.tar.gz::https://github.com/jpvanhal/inflection/archive/$pkgver.tar.gz"
+builddir="$srcdir"/inflection-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py --quiet build
+ python3 setup.py --quiet build
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/bin
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="2a69a6228f2d44a5afecbd3ef51a51b4d5f63f69ddc844f4abfd6f326cb25c518403e8c5b9f98589885777d41d8fea31bacab3a5a3ab80db411960238d2f49ad py-inflection-0.3.1.tar.gz"