aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-29 16:38:27 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-29 16:59:18 +0200
commita0ff250b95d759394ac4c686b01037c1429f3a49 (patch)
tree9add6a149cbd8a181b9b6b96175f00a84cce3b99
parente7d9d6353d4454eef61ba3262f05ccb7b525c0b9 (diff)
downloadaports-a0ff250b95d759394ac4c686b01037c1429f3a49.tar.bz2
aports-a0ff250b95d759394ac4c686b01037c1429f3a49.tar.xz
testing/py3-cachetools: new aport
https://github.com/tkem/cachetools Extensible memoizing collections and decorators
-rw-r--r--testing/py3-cachetools/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-cachetools/APKBUILD b/testing/py3-cachetools/APKBUILD
new file mode 100644
index 0000000000..fa415151b5
--- /dev/null
+++ b/testing/py3-cachetools/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=py3-cachetools
+_pkgname=cachetools
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="Extensible memoizing collections and decorators"
+url="https://github.com/tkem/cachetools"
+arch="noarch"
+license="MIT"
+depends="python3"
+checkdepends="py3-pytest"
+makedepends="python3-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tkem/cachetools/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 -m pytest .
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="359f0b57c34af96d4c8cfac19daa591e357db19c592ce89449001593f3044affb6e6109e1d2b63666dd8c95c6c496387032759d2ef01e5d5ae93eef39df15d72 py3-cachetools-2.1.0.tar.gz"