aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Searle <joe@jsearle.net>2019-09-24 16:59:47 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-09-24 16:33:12 -0300
commita298c649a1ade48b1be4caeb48c660a8863ebad6 (patch)
treec27f38ede67aae65ceb4f337a9fd6ad6a36c16e9
parent140ed4e4f9fa18f3f1dee83d01b7718b898c1486 (diff)
downloadaports-a298c649a1ade48b1be4caeb48c660a8863ebad6.tar.bz2
aports-a298c649a1ade48b1be4caeb48c660a8863ebad6.tar.xz
testing/peek: upgrade to 1.4.0
-rw-r--r--testing/peek/APKBUILD10
-rw-r--r--testing/peek/CMakeLists.txt.patch30
2 files changed, 35 insertions, 5 deletions
diff --git a/testing/peek/APKBUILD b/testing/peek/APKBUILD
index 1d63857220..0cccce32ba 100644
--- a/testing/peek/APKBUILD
+++ b/testing/peek/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=peek
-pkgver=1.3.1
+pkgver=1.4.0
pkgrel=0
pkgdesc="Simple animated GIF screen recorder with an easy to use interface"
url="https://github.com/phw/peek"
@@ -10,8 +10,8 @@ license="GPL-3.0-or-later"
depends="ffmpeg gst-plugins-good gst-plugins-bad"
makedepends="cmake gtk+3.0-dev gettext-dev vala txt2man"
subpackages="$pkgname-lang $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/phw/peek/archive/${pkgver}.tar.gz
- fix-parallel-build.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/phw/peek/archive/$pkgver.tar.gz
+ CMakeLists.txt.patch"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -37,5 +37,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="cdf4190c555b0a40051862038c04dc7c164bf8bccf47202d0fcb74f527a8a7d5605bc2e112847e262e51a5a95c3d2b3497e4ec56834880564e8e4127869ad9df peek-1.3.1.tar.gz
-bef691c81d25d4476976fa9db0f8e0946b40ccaf039dbd64f20eb31dc3a1bbc80b993b74a1e1d03e30900f3661e4c5ba35ad4b5b8e17ddf896bf4947d418e56c fix-parallel-build.patch"
+sha512sums="ef1723f72d1c575493b2e9192cee6038807d37d875a797781169e5f4640635deda947362dcf2e1a9149fcfe88de532b8ea05c665b14b1befaa9aa8c982d9aa31 peek-1.4.0.tar.gz
+b85268fad2d9c2845da3d5f5eee827ef330fc284a4569c862abe9da1d27bb36d72c26d9018728fdb4d51b7288b772392c65d5a4d6674037a6b37b854a23dcf8b CMakeLists.txt.patch"
diff --git a/testing/peek/CMakeLists.txt.patch b/testing/peek/CMakeLists.txt.patch
new file mode 100644
index 0000000000..8dcbf3c217
--- /dev/null
+++ b/testing/peek/CMakeLists.txt.patch
@@ -0,0 +1,30 @@
+From 3c996ee9201f8b6d385966a2a1e60829734d9643 Mon Sep 17 00:00:00 2001
+From: Philipp Wolfer <phil@parolu.io>
+Date: Tue, 24 Sep 2019 18:36:03 +0200
+Subject: [PATCH] Fixed icon installation with cmake (#504)
+
+---
+ data/CMakeLists.txt | 10 ++--------
+ 1 file changed, 2 insertions(+), 8 deletions(-)
+
+diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
+index ea628ba..63b4076 100644
+--- a/data/CMakeLists.txt
++++ b/data/CMakeLists.txt
+@@ -55,14 +55,8 @@ else()
+ endif()
+
+ # Install application icons
+-install(FILES "icons/16x16/com.uploadedlobster.peek.png" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/16x16/apps)
+-install(FILES "icons/24x24/com.uploadedlobster.peek.png" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/24x24/apps)
+-install(FILES "icons/32x32/com.uploadedlobster.peek.png" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/32x32/apps)
+-install(FILES "icons/48x48/com.uploadedlobster.peek.png" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/48x48/apps)
+-install(FILES "icons/64x64/com.uploadedlobster.peek.png" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/64x64/apps)
+-install(FILES "icons/128x128/com.uploadedlobster.peek.png" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/128x128/apps)
+-install(FILES "icons/256x256/com.uploadedlobster.peek.png" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/256x256/apps)
+-install(FILES "icons/512x512/com.uploadedlobster.peek.png" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/512x512/apps)
++install(FILES "icons/com.uploadedlobster.peek.svg" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/scalable/apps)
++install(FILES "icons/com.uploadedlobster.peek-symbolic.svg" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/symbolic/apps)
+
+ # Install DBus service
+ configure_file (