aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 14:39:17 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 14:39:17 -0300
commitbc8bb9e6569c6f59fc367a7baaee2292f41abc0c (patch)
treef7f107b2ecf1bfd3a3e5837fe15953c566e9a05e
parent21d3a0fdf5693b8c8301efd1e3332e911833a1a9 (diff)
downloadaports-bc8bb9e6569c6f59fc367a7baaee2292f41abc0c.tar.bz2
aports-bc8bb9e6569c6f59fc367a7baaee2292f41abc0c.tar.xz
testing/py3-coreapi: new aport
https://github.com/core-api/python-client Python3 client library for Core API
-rw-r--r--testing/py3-coreapi/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-coreapi/APKBUILD b/testing/py3-coreapi/APKBUILD
new file mode 100644
index 0000000000..74e2b7b2e0
--- /dev/null
+++ b/testing/py3-coreapi/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-coreapi
+_pkgname=python-client
+pkgver=2.3.3
+pkgrel=0
+pkgdesc="Python3 client library for Core API"
+url="https://github.com/core-api/python-client"
+arch="noarch"
+license="BSD-3-Clause"
+depends="py3-setuptools py3-coreschema py3-requests py3-itypes py3-uritemplate"
+checkdepends="py3-pytest py3-coverage"
+source="$pkgname-$pkgver.tar.gz::https://github.com/core-api/python-client/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$PWD/build/lib" py.test-3
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="aeae3ace84c0ce61552236b83db28e47492f5ac17a0e216e1a8eeddaf67270b94127f7a40f8a37cc5051abe097555adfd690a7e6c8801524ca77c916bd451ab8 py3-coreapi-2.3.3.tar.gz"