aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-25 11:40:29 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-25 11:53:59 -0300
commit2ed6226fc6f48fac1f5b86d68d774d6e54c4a025 (patch)
treed09c630030e347373bc9c7e59938b0a02c097d21
parent7dcf1b9988ce780d8c3686d3a612dcf04da1f561 (diff)
downloadaports-2ed6226fc6f48fac1f5b86d68d774d6e54c4a025.tar.bz2
aports-2ed6226fc6f48fac1f5b86d68d774d6e54c4a025.tar.xz
testing/telegram-tdlib: upgrade to 1.5.0
-rw-r--r--testing/telegram-tdlib/APKBUILD9
-rw-r--r--testing/telegram-tdlib/sysctl_h.patch13
2 files changed, 19 insertions, 3 deletions
diff --git a/testing/telegram-tdlib/APKBUILD b/testing/telegram-tdlib/APKBUILD
index c596fb1259..57477a8e1c 100644
--- a/testing/telegram-tdlib/APKBUILD
+++ b/testing/telegram-tdlib/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Oleg Titov <oleg.titov@gmail.com>
# Maintainer: Oleg Titov <oleg.titov@gmail.com>
pkgname=telegram-tdlib
-pkgver=1.4.0
+pkgver=1.5.0
pkgrel=0
pkgdesc="Cross-platform library for building Telegram clients"
url="https://core.telegram.org/tdlib"
@@ -10,7 +10,9 @@ license="BSL-1.0"
options="!check" # No test suite from upstream
makedepends="cmake openssl-dev zlib-dev gperf linux-headers"
subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/tdlib/td/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tdlib/td/archive/v$pkgver.tar.gz
+ sysctl_h.patch
+ "
builddir="$srcdir/td-$pkgver"
build() {
@@ -32,4 +34,5 @@ package() {
README.md
}
-sha512sums="6484d09408afbca2062cc87080b536431a9a6bd4179b220a0335d8aef591de5d35c99906e8d67c0d8c684b02b63b82d12bd064dc265d2416561c1136051eb4b1 telegram-tdlib-1.4.0.tar.gz"
+sha512sums="57f7dcaacd253d06852d95e210c6ecefa3d477f36d74f1f934a9affb621e99258bd631b7c3573df84812f9f44e6ceb090fbbc62e9f541c5d539fbab0ee51a222 telegram-tdlib-1.5.0.tar.gz
+f90e2e40c8a85b2df4fe7149e6cbf399b228f9084b25d8d48d38a1b9315ab536c8a68a0d910e17445b54a793411e77df530c16b08e405385b12ca1d35ddf3f53 sysctl_h.patch"
diff --git a/testing/telegram-tdlib/sysctl_h.patch b/testing/telegram-tdlib/sysctl_h.patch
new file mode 100644
index 0000000000..68a5119aca
--- /dev/null
+++ b/testing/telegram-tdlib/sysctl_h.patch
@@ -0,0 +1,13 @@
+diff --git a/tdutils/td/utils/port/detail/ThreadPthread.cpp b/tdutils/td/utils/port/detail/ThreadPthread.cpp
+index c712cef..c0cb69b 100644
+--- a/tdutils/td/utils/port/detail/ThreadPthread.cpp
++++ b/tdutils/td/utils/port/detail/ThreadPthread.cpp
+@@ -14,7 +14,6 @@ char disable_linker_warning_about_empty_file_thread_pthread_cpp TD_UNUSED;
+
+ #include <pthread.h>
+ #include <sched.h>
+-#include <sys/sysctl.h>
+ #include <unistd.h>
+
+ namespace td {
+