aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2018-02-14 03:38:39 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-14 03:38:39 +0000
commit304fa238dc482489954c4107c5b8413bc2a7740d (patch)
tree57953c44583ebcf6f2e8bfa00b672d56bfde587a
parent498d4de2545ce405010d14a88f9f360a48968ad3 (diff)
downloadaports-304fa238dc482489954c4107c5b8413bc2a7740d.tar.bz2
aports-304fa238dc482489954c4107c5b8413bc2a7740d.tar.xz
testing/libucontext: kill x86 textrel, reenable tests there
-rw-r--r--testing/libucontext/0002-x86-trampoline-kill-textrel.patch25
-rw-r--r--testing/libucontext/APKBUILD9
2 files changed, 29 insertions, 5 deletions
diff --git a/testing/libucontext/0002-x86-trampoline-kill-textrel.patch b/testing/libucontext/0002-x86-trampoline-kill-textrel.patch
new file mode 100644
index 0000000000..af60558ba4
--- /dev/null
+++ b/testing/libucontext/0002-x86-trampoline-kill-textrel.patch
@@ -0,0 +1,25 @@
+From 0143bbac98dfd55c4a42652bd1cce8d35047a861 Mon Sep 17 00:00:00 2001
+From: William Pitcock <nenolod@dereferenced.org>
+Date: Wed, 14 Feb 2018 03:37:25 +0000
+Subject: [PATCH 2/2] x86: trampoline: kill textrel
+
+---
+ arch/x86/startcontext.S | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/arch/x86/startcontext.S b/arch/x86/startcontext.S
+index 165804d..2bb87ee 100644
+--- a/arch/x86/startcontext.S
++++ b/arch/x86/startcontext.S
+@@ -18,7 +18,7 @@ __start_context:
+ je hosed
+
+ /* call setcontext to switch to the linked context */
+- call __setcontext
++ call __setcontext@plt
+ movl %eax, (%esp)
+
+ hosed:
+--
+2.16.1
+
diff --git a/testing/libucontext/APKBUILD b/testing/libucontext/APKBUILD
index ce2e555929..aab524d79f 100644
--- a/testing/libucontext/APKBUILD
+++ b/testing/libucontext/APKBUILD
@@ -10,12 +10,10 @@ depends=""
install=""
subpackages="$pkgname-dev"
source="https://distfiles.dereferenced.org/libucontext/libucontext-$pkgver.tar.xz
- 0001-build-use-absolute-path-for-LD_LIBRARY_PATH-when-tes.patch"
+ 0001-build-use-absolute-path-for-LD_LIBRARY_PATH-when-tes.patch
+ 0002-x86-trampoline-kill-textrel.patch"
builddir="$srcdir/libucontext-$pkgver"
-# grsecurity doesn't like the LD_LIBRARY_PATH thing for some reason it seems
-[ "$CTARGET_ARCH" = "x86" ] && options="!check"
-
case "$CTARGET_ARCH" in
ppc64le) LIBUCONTEXT_ARCH="ppc64" ;;
*) LIBUCONTEXT_ARCH="$CTARGET_ARCH" ;;
@@ -37,4 +35,5 @@ package() {
}
sha512sums="abeae370317c53e6656842edd619e87202865d8f8808808f5ec5dfd40c259dcdc3ee530e0227ae602ca255215cf472e99ad1e3fbbb54f362c5a3cf744d9a1be4 libucontext-0.1.0.tar.xz
-26e1933e822ddc83086295144e5e8dc09602ad9200703b0e8c832bee0ee335c62c758d9847058bb28baf248f825d00604cfa1b4cb9b48234760c0e92cafb296a 0001-build-use-absolute-path-for-LD_LIBRARY_PATH-when-tes.patch"
+26e1933e822ddc83086295144e5e8dc09602ad9200703b0e8c832bee0ee335c62c758d9847058bb28baf248f825d00604cfa1b4cb9b48234760c0e92cafb296a 0001-build-use-absolute-path-for-LD_LIBRARY_PATH-when-tes.patch
+dbcd8613379383fa488f525430383e2cf472c674b342f3f056f59081c73632fc8800bd22e1245ea5c2779039a095ed78bdac756f5037870115f4087b5dc3bd00 0002-x86-trampoline-kill-textrel.patch"