aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-03-29 03:40:23 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-03-29 03:40:23 +0000
commit826bc345b4b18e0fae49785faa3faa52423b0d7c (patch)
treeed10648f932cef6fbd7d7097bd53d3acb63b560e
parent8c5c18288416d0b75bb58e3d5bc10bcb9a67b949 (diff)
downloadaports-826bc345b4b18e0fae49785faa3faa52423b0d7c.tar.bz2
aports-826bc345b4b18e0fae49785faa3faa52423b0d7c.tar.xz
testing/{ipt-netflow-grsec,sch-cacke-grsec,wireguard-grsec}: fix $arch
we only ship linux-grsec on x86/x86_64/armhf, and there are no plans to ship it on any other archs, so $arch=all is improper.
-rw-r--r--testing/ipt-netflow-grsec/APKBUILD2
-rw-r--r--testing/sch-cake-grsec/APKBUILD2
-rw-r--r--testing/wireguard-grsec/APKBUILD2
3 files changed, 3 insertions, 3 deletions
diff --git a/testing/ipt-netflow-grsec/APKBUILD b/testing/ipt-netflow-grsec/APKBUILD
index 96c61429c8..8987d0b8cf 100644
--- a/testing/ipt-netflow-grsec/APKBUILD
+++ b/testing/ipt-netflow-grsec/APKBUILD
@@ -27,7 +27,7 @@ pkgver=$_kver
pkgrel=$(( $_kpkgrel + $_mypkgrel ))
pkgdesc="Linux kernel netflow sensor module"
url="http://ipt-netflow.sourceforge.net/"
-arch="all !aarch64"
+arch="x86 x86_64 armhf"
license=GPL3+
source="ipt-netflow-$_ver.tar.gz::https://github.com/aabc/ipt-netflow/archive/v$_ver.tar.gz
kernel-4.6.patch
diff --git a/testing/sch-cake-grsec/APKBUILD b/testing/sch-cake-grsec/APKBUILD
index 5cfaeaaafa..ffa509b316 100644
--- a/testing/sch-cake-grsec/APKBUILD
+++ b/testing/sch-cake-grsec/APKBUILD
@@ -28,7 +28,7 @@ pkgrel=$(($_kpkgrel + $_mypkgrel))
pkgrel=0
pkgdesc="Out of tree build for the new cake qdisc"
url="https://github.com/dtaht/sch_cake"
-arch="all !aarch64"
+arch="x86 x86_64 armhf"
license="Dual BSD/GPL"
depends="linux-${_flavor}=${_kernelver}"
makedepends="linux-${_flavor}-dev=${_kernelver} linux-headers"
diff --git a/testing/wireguard-grsec/APKBUILD b/testing/wireguard-grsec/APKBUILD
index 5760742650..892d435bb5 100644
--- a/testing/wireguard-grsec/APKBUILD
+++ b/testing/wireguard-grsec/APKBUILD
@@ -27,7 +27,7 @@ pkgname=${_name}-${_flavor}
pkgver=$_kver
pkgrel=$(($_kpkgrel + $_mypkgrel))
pkgdesc="Next generation secure network tunnel: kernel modules for $_flavor"
-arch='all !aarch64'
+arch='x86 x86_64 armhf'
url='https://www.wireguard.io'
license="GPLv2"
makedepends="linux-grsec-dev=$_kpkgver libmnl-dev"