aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Li <andy@onthewings.net>2017-12-28 14:54:22 +0800
committerWilliam Pitcock <nenolod@dereferenced.org>2017-12-28 21:28:53 +0000
commitd6970b81c740d31c990195628e68a736bc97b5b2 (patch)
treea7e1824e4d91376f902799c2062b2e39573c9fe3
parenteb263356048d467ca4c006071332756b49c95877 (diff)
downloadaports-d6970b81c740d31c990195628e68a736bc97b5b2.tar.bz2
aports-d6970b81c740d31c990195628e68a736bc97b5b2.tar.xz
testing/neko: upgrade to 2.2.0
-rw-r--r--testing/neko/APKBUILD21
-rw-r--r--testing/neko/compilation-fixes.patch27
-rw-r--r--testing/neko/mincoming-stack-boundary.patch36
-rw-r--r--testing/neko/nojit.patch11
4 files changed, 7 insertions, 88 deletions
diff --git a/testing/neko/APKBUILD b/testing/neko/APKBUILD
index de4ce07b15..cde0aea6be 100644
--- a/testing/neko/APKBUILD
+++ b/testing/neko/APKBUILD
@@ -1,24 +1,20 @@
# Contributor: Jon Ong <jonongjs@rottenmage.com>
# Maintainer: Andy Li <andy@onthewings.net>
pkgname=neko
-pkgver=2.1.0
-pkgrel=2
+pkgver=2.2.0
+pkgrel=0
pkgdesc="High-level dynamically typed programming language"
-url="http://nekovm.org/"
+url="https://nekovm.org/"
arch="all"
license="LGPL"
depends=""
depends_dev="neko"
makedepends="apache2-dev cmake gc-dev gtk+2.0-dev linux-headers mariadb-dev
mbedtls-dev ninja sqlite-dev"
-options="!strip"
+options=""
install=""
subpackages="$pkgname-dev $pkgname-libs"
-source="$pkgname-$pkgver.tar.gz::https://github.com/HaxeFoundation/neko/archive/v${pkgver//./-}.tar.gz
- compilation-fixes.patch
- nojit.patch
- mincoming-stack-boundary.patch
- "
+source="$pkgname-$pkgver.tar.gz::https://github.com/HaxeFoundation/neko/archive/v${pkgver//./-}.tar.gz"
builddir="$srcdir/$pkgname-${pkgver//./-}"
build() {
@@ -27,7 +23,7 @@ build() {
mkdir -p build || return 1
cd build || return 1
- cmake "../" -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -GNinja || return 1
+ cmake "../" -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DNEKO_JIT_DISABLE=ON -GNinja || return 1
ninja || return 1
}
@@ -40,7 +36,4 @@ package() {
cd "$builddir"
DESTDIR="$pkgdir" ninja -C build install || return 1
}
-sha512sums="a3a4e1064cf3a73b07d39eba62b261b3e954a74d71f588e90904ebdab2f3fc9f75c37a0788de0a354df9fddff412076cc321b6b33d529e69acccf403889a01b0 neko-2.1.0.tar.gz
-8d2c7be3db571f1bd1efe75209941fb1c2feb133015950be70aa31a7d55e4f5918ddb84bde4bbcce514b876c93173d7d7157481e7ce9e96d98c4229e7695d9ee compilation-fixes.patch
-60023ab071fdaed40ccfcf452b7490f52bde04eac1586e66d93206dec66d2fb5f00a013dc93e4310dd40a0ca3e340e3b27a67ae9bb55a7a604d81e7a60acc01d nojit.patch
-bf6a42154070e9d7d5b65f9094f070e8d4965e4828f6b98d46ae4959a6cc13fbb3b46739e12b5125941da6ea9293ed0dd4d149885331925356395940d14e94ac mincoming-stack-boundary.patch"
+sha512sums="4bc89fddf4a5ae94e73843b06a3b6fe8de59d72922764276a5bd9d56daf6570525e842039bf704598b41e1de4a5fe08931adc4ca9730fe3333be0beb7a1ccaed neko-2.2.0.tar.gz"
diff --git a/testing/neko/compilation-fixes.patch b/testing/neko/compilation-fixes.patch
deleted file mode 100644
index 666c017be1..0000000000
--- a/testing/neko/compilation-fixes.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/libs/std/sys.c b/libs/std/sys.c
-index 8003d41..fc59b01 100644
---- a/libs/std/sys.c
-+++ b/libs/std/sys.c
-@@ -41,7 +41,6 @@
- # include <sys/time.h>
- # include <sys/times.h>
- # include <sys/wait.h>
--# include <xlocale.h>
- #endif
-
- #ifdef NEKO_MAC
-diff --git a/vm/module.c b/vm/module.c
-index 7f857af..34afa52 100644
---- a/vm/module.c
-+++ b/vm/module.c
-@@ -34,6 +34,10 @@ DEFINE_KIND(neko_kind_module);
- #ifdef NEKO_BSD
- # include <sys/endian.h>
- #endif
-+#ifdef __GNUC__
-+# include <endian.h>
-+#define BYTE_ORDER __BYTE_ORDER
-+#endif
- #ifndef LITTLE_ENDIAN
- # define LITTLE_ENDIAN 1
- #endif
diff --git a/testing/neko/mincoming-stack-boundary.patch b/testing/neko/mincoming-stack-boundary.patch
deleted file mode 100644
index 30c6e98275..0000000000
--- a/testing/neko/mincoming-stack-boundary.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 4b78044643c459a63bc87f6eadd50991df0301c7 Mon Sep 17 00:00:00 2001
-From: Andy Li <andy@onthewings.net>
-Date: Mon, 6 Jun 2016 22:22:57 +0000
-Subject: [PATCH] only use -mincoming-stack-boundary when it is available
- From upstream: https://github.com/HaxeFoundation/neko/commit/4b78044643c459a63bc87f6eadd50991df0301c7
-
----
- CMakeLists.txt | 9 ++++++++-
- 1 file changed, 8 insertions(+), 1 deletion(-)
-
-Index: neko-debian/CMakeLists.txt
-===================================================================
---- neko-debian.orig/CMakeLists.txt
-+++ neko-debian/CMakeLists.txt
-@@ -1,5 +1,6 @@
- cmake_minimum_required(VERSION 2.8.7)
-
-+include(CheckCCompilerFlag)
- project(neko C)
-
- set(CMAKE_OSX_ARCHITECTURES x86_64)
-@@ -191,7 +192,13 @@ if(UNIX)
-
- # https://github.com/HaxeFoundation/neko/pull/17
- if(CMAKE_SIZEOF_VOID_P EQUAL 4)
-- add_compile_options(-mincoming-stack-boundary=2)
-+ check_c_compiler_flag(-mincoming-stack-boundary=2 HAS_MINCOMING_STACK_BOUNDARY)
-+ check_c_compiler_flag(-mstack-alignment=2 HAS_MSTACK_ALIGNMENT)
-+ if(HAS_MINCOMING_STACK_BOUNDARY)
-+ add_compile_options(-mincoming-stack-boundary=2)
-+ elseif(HAS_MSTACK_ALIGNMENT)
-+ add_compile_options(-mstack-alignment=2)
-+ endif()
- endif()
-
- find_package(PkgConfig REQUIRED)
diff --git a/testing/neko/nojit.patch b/testing/neko/nojit.patch
deleted file mode 100644
index 8bbbfff40e..0000000000
--- a/testing/neko/nojit.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/vm/jit_x86.c
-+++ b/vm/jit_x86.c
-@@ -37,7 +37,7 @@
- #define tmp_free(ptr) free(ptr)
-
- #if defined(NEKO_X86) && !defined(NEKO_MAC)
--#define JIT_ENABLE
-+//#define JIT_ENABLE
- #endif
-
- #ifdef NEKO_MAC