aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-07-22 07:33:57 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-07-22 07:33:57 +0000
commiteb9cdd064ecb7e3292e39a4ca3418e9d9b53f6c8 (patch)
tree7dae558f2d53891d560de9441dffc5aa9b90ba81
parentba84c8cd448c7a6f60e7c9e760f212e8dd3b0ffb (diff)
downloadaports-eb9cdd064ecb7e3292e39a4ca3418e9d9b53f6c8.tar.bz2
aports-eb9cdd064ecb7e3292e39a4ca3418e9d9b53f6c8.tar.xz
community/greenbone-security-assistant: upgrade to 8.0.1
-rw-r--r--community/greenbone-security-assistant/APKBUILD8
-rw-r--r--community/greenbone-security-assistant/musl-stack-size.patch26
2 files changed, 17 insertions, 17 deletions
diff --git a/community/greenbone-security-assistant/APKBUILD b/community/greenbone-security-assistant/APKBUILD
index 8a36048014..2a4df3ab73 100644
--- a/community/greenbone-security-assistant/APKBUILD
+++ b/community/greenbone-security-assistant/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=greenbone-security-assistant
_pkgname=gsad
-pkgver=8.0.0
-pkgrel=4
+pkgver=8.0.1
+pkgrel=0
pkgdesc="Greenbone Security Assistant (gsa) - OpenVAS web frontend"
url="http://www.openvas.org/"
arch="all"
@@ -44,11 +44,11 @@ package() {
install -Dm755 "$srcdir/$_pkgname.confd" "$pkgdir/etc/conf.d/$_pkgname"
}
-sha512sums="b3bc464548d6ecef8d515e69f9824d064b90c3da677f262fb040b2750b2c15cd14dfe2c7db3f830ce9d9d8bfb7d1591cc78c1c860d7b8a3417af03c78f99813f greenbone-security-assistant-8.0.0.tar.gz
+sha512sums="b91c1c4b8073c3ad3d3d636abbaa7881393f1448eae7366636ff618391c199c240e6bc4c848740a4267b4142aa872fb91c0798b8034d152d16016e650fbda2b8 greenbone-security-assistant-8.0.1.tar.gz
0734d3b7dc77b8de56dec63e677aefad14dcb718b5f3081f98738397c267d4fb36bbb167085213bc1d02d9261e4913f43f974f65226c459f9dfed0d970cf9b85 gsad.initd
aea96cef16ca7a63570c2d94a1fc7ef27d4163c28e1d729fd11821295f88a96864add0146d407e7b6de296dd6ca6f2c97d72097dd4ffe786b575f128abdbb1bf gsad.confd
0d459084f95e00dfb06912b9d89af011fac117a32687ffd3da3887c24e80c074b681c0d87532a4a7511e42c540f8d8b2ceaa04208fff531b94047a08decddd0f gsad.logrotate
6752bb6834811fc7c1259d2c8a0ae5f25a01de881008f6f6635b1f7a43672b5c1862de5b3591f81d7a2f22258614b71bb6ab588a3930648d9d74ef8a75d28c92 cmakelist.patch
1fd6585bc5c5131d19d5d89ddc56b683d5ab1b28793059f5b147ad05eb6330b69d590caa2f12afce6da20b1676d8cdd26d90e51d165e94b308643ec7d2525015 sys-siglist.patch
-5083162dd8f324e102731f691f575adb791861d13d857e37bf0e2aa39b875facae8e7b1ad37a0d60860495603df90ef785cab13685c4405d14e06aca1d8bfe5e musl-stack-size.patch
+ad78cce9f4f21157d679e227698896364c33eac9c5af4228552b61c0f9bde0e3b2743ae6717766acde38d5445d08e60832b2b0418456cdb8a77a91b3c440735b musl-stack-size.patch
61a2ad4f6f5742de36e1468f5c4f6d85099e9b8c6be805eb08aea05ffed183d1d972063596193e5e2305d4c133392a698123e364e1e0fe5c90889b50f235172a remove-husky-git-hook.patch"
diff --git a/community/greenbone-security-assistant/musl-stack-size.patch b/community/greenbone-security-assistant/musl-stack-size.patch
index 8a64f23557..62d0f61558 100644
--- a/community/greenbone-security-assistant/musl-stack-size.patch
+++ b/community/greenbone-security-assistant/musl-stack-size.patch
@@ -1,28 +1,28 @@
diff --git a/gsad/src/gsad.c b/gsad/src/gsad.c
-index efdecfc..7d7e13d 100644
+index f176b62..37a9d66 100644
--- a/gsad/src/gsad.c
+++ b/gsad/src/gsad.c
-@@ -2598,6 +2598,7 @@ start_unix_http_daemon (const char *unix_socket_path,
+@@ -2556,6 +2556,7 @@ start_unix_http_daemon (const char *unix_socket_path,
0, NULL, NULL, handler, http_handlers, MHD_OPTION_NOTIFY_COMPLETED,
free_resources, NULL, MHD_OPTION_LISTEN_SOCKET, unix_socket,
MHD_OPTION_PER_IP_CONNECTION_LIMIT, get_per_ip_connection_limit (),
-+ MHD_OPTION_THREAD_STACK_SIZE, (size_t) 4*1024*1024,
++ MHD_OPTION_THREAD_STACK_SIZE, (size_t) 4*1024*1024,
MHD_OPTION_EXTERNAL_LOGGER, mhd_logger, NULL, MHD_OPTION_END);
}
-@@ -2626,6 +2627,7 @@ start_http_daemon (int port,
- port, NULL, NULL, handler, http_handlers, MHD_OPTION_NOTIFY_COMPLETED,
- free_resources, NULL, MHD_OPTION_SOCK_ADDR, address,
- MHD_OPTION_PER_IP_CONNECTION_LIMIT, get_per_ip_connection_limit (),
-+ MHD_OPTION_THREAD_STACK_SIZE, (size_t) 4*1024*1024,
+@@ -2590,6 +2591,7 @@ start_http_daemon (int port,
+ flags, port, NULL, NULL, handler, http_handlers,
+ MHD_OPTION_NOTIFY_COMPLETED, free_resources, NULL, MHD_OPTION_SOCK_ADDR,
+ address, MHD_OPTION_PER_IP_CONNECTION_LIMIT, get_per_ip_connection_limit (),
++ MHD_OPTION_THREAD_STACK_SIZE, (size_t) 4*1024*1024,
MHD_OPTION_EXTERNAL_LOGGER, mhd_logger, NULL, MHD_OPTION_END);
}
-@@ -2653,6 +2655,7 @@ start_https_daemon (int port, const char *key, const char *cert,
- key, MHD_OPTION_HTTPS_MEM_CERT, cert, MHD_OPTION_NOTIFY_COMPLETED,
- free_resources, NULL, MHD_OPTION_SOCK_ADDR, address,
- MHD_OPTION_PER_IP_CONNECTION_LIMIT, get_per_ip_connection_limit (),
-+ MHD_OPTION_THREAD_STACK_SIZE, (size_t) 4*1024*1024,
+@@ -2623,6 +2625,7 @@ start_https_daemon (int port, const char *key, const char *cert,
+ MHD_OPTION_HTTPS_MEM_KEY, key, MHD_OPTION_HTTPS_MEM_CERT, cert,
+ MHD_OPTION_NOTIFY_COMPLETED, free_resources, NULL, MHD_OPTION_SOCK_ADDR,
+ address, MHD_OPTION_PER_IP_CONNECTION_LIMIT, get_per_ip_connection_limit (),
++ MHD_OPTION_THREAD_STACK_SIZE, (size_t) 4*1024*1024,
MHD_OPTION_HTTPS_PRIORITIES, priorities, MHD_OPTION_EXTERNAL_LOGGER,
mhd_logger, NULL,
/* LibmicroHTTPD 0.9.35 and higher. */