aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-10 23:20:44 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-11 21:37:43 +0100
commitf8753eee6924f65582182601adf1b44fd73c57f8 (patch)
treefd347605336177cc8e8beb210da13926bf379c5a
parent2109a58605485138ebe3a5cc2913c5b716ab48aa (diff)
downloadaports-f8753eee6924f65582182601adf1b44fd73c57f8.tar.bz2
aports-f8753eee6924f65582182601adf1b44fd73c57f8.tar.xz
testing/ocaml-topkg: new aport
http://erratique.ch/software/topkg The transitory OCaml software packager
-rw-r--r--testing/ocaml-topkg/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/ocaml-topkg/APKBUILD b/testing/ocaml-topkg/APKBUILD
new file mode 100644
index 0000000000..ec92316f7c
--- /dev/null
+++ b/testing/ocaml-topkg/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+# FIXME: run tests!
+pkgname=ocaml-topkg
+_pkgname=topkg
+pkgver=0.9.1
+pkgrel=0
+pkgdesc="The transitory OCaml software packager"
+url="http://erratique.ch/software/topkg"
+arch="all !x86 !armhf !s390x" # limited by ocaml aport
+license="ISC"
+depends="ocaml-result ocaml-runtime"
+depends_dev="$pkgname=$pkgver-r$pkgrel"
+makedepends="ocaml ocaml-compiler-libs ocaml-findlib ocaml-result-dev ocamlbuild opam"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/dbuenzli/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ocaml pkg/pkg.ml build
+}
+
+package() {
+ cd "$builddir"
+
+ opam-installer -i \
+ --prefix="$pkgdir/usr" \
+ --libdir="$pkgdir/usr/lib/ocaml" \
+ --docdir="$builddir/.omit" \
+ $_pkgname.install
+
+ # Remove annotation files.
+ rm -Rf "$pkgdir"/usr/lib/ocaml/$_pkgname/*.cmt*
+}
+
+dev() {
+ local sitelib="usr/lib/ocaml/$_pkgname"
+ default_dev
+
+ cd "$pkgdir"/$sitelib
+
+ mkdir -p "$subpkgdir"/$sitelib
+ mv *.cmx *.cmxa *.mli "$subpkgdir"/$sitelib/
+}
+
+sha512sums="19773eb764b53a6e5110c44d7942d2557d6c8502a3037b57f7737efc08f4cc374845b431fdb1465207693d15a4b072aea3db97f8e60e069e3d24ae150e8c5c8f ocaml-topkg-0.9.1.tar.gz"