aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-10-13 19:05:21 +0200
committerJakub Jirutka <jakub@jirutka.cz>2019-10-20 20:51:35 +0200
commit1f6a389d2919c93e08c87b103e11c8c5bcf9c2df (patch)
treed75278a90f233bcdd80471ab9f8ebbee6c0a5dca
parentf8ebef55809aa32e4a90bdbce6f251556758bd41 (diff)
downloadaports-1f6a389d2919c93e08c87b103e11c8c5bcf9c2df.tar.bz2
aports-1f6a389d2919c93e08c87b103e11c8c5bcf9c2df.tar.xz
main/pspg: upgrade to 2.1.7
fix fix-musl.patch
-rw-r--r--main/pspg/APKBUILD6
-rw-r--r--main/pspg/fix-musl.patch5
2 files changed, 4 insertions, 7 deletions
diff --git a/main/pspg/APKBUILD b/main/pspg/APKBUILD
index 21cad2db1e..5fb7cf64f6 100644
--- a/main/pspg/APKBUILD
+++ b/main/pspg/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=pspg
-pkgver=1.6.8
+pkgver=2.1.7
pkgrel=0
pkgdesc="A unix pager optimized for psql"
url="https://github.com/okbob/pspg"
@@ -38,5 +38,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="337ae1eb9e92dc97ca32127322aaa3d0c5edb8766e5cab16e778148b3256119c7c5b1b2e4b6ab0b520113ede07c464d1c1c5e460c8efb7714f5a29acfa845e9d pspg-1.6.8.tar.gz
-5756abc912e3fd8a3bfabdb5bb7e6dd2eb2480d2cfc1f2e69961e3209059339c1a3ea50216df6c724e22da033455abb94452f2502be48e089679a87ef5242619 fix-musl.patch"
+sha512sums="8f99aedf999452fdd1863726aeab36fb98bf6827a04e21b9e81c66043bd3d4bdb733764348971c7d67eb4bd12d252e81ca3161b0c261b235d113c4940a74c0f0 pspg-2.1.7.tar.gz
+b1538580f0ba1d24f3b66cad611c0ddcc9d5b74e6f7e5a46a74b1271db957b7094d64b0eefbdea51a6e7c9297a5d914ef7e6e759d24da724bc1276bdf1614940 fix-musl.patch"
diff --git a/main/pspg/fix-musl.patch b/main/pspg/fix-musl.patch
index b7d889d67b..9b66808d53 100644
--- a/main/pspg/fix-musl.patch
+++ b/main/pspg/fix-musl.patch
@@ -1,5 +1,3 @@
-diff --git a/src/unicode.c b/src/unicode.c
-index 4dbfa6b..3bbf70f 100644
--- a/src/unicode.c
+++ b/src/unicode.c
@@ -11,6 +11,8 @@
@@ -8,7 +6,6 @@ index 4dbfa6b..3bbf70f 100644
+#define _GNU_SOURCE 1
+#include <sys/types.h>
+ #include <ctype.h>
#include <stdbool.h>
- #include "unicode.h"
-