aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-29 13:45:29 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-30 10:59:20 -0300
commit2584f7e32ac2faa4ffdb41258707409def05ab30 (patch)
treefa140fd46f69ee9344a78af89b1c3ad9dc33a58d
parent96223ebf2ba82b6fbba06cdb0781df307d200cab (diff)
downloadaports-2584f7e32ac2faa4ffdb41258707409def05ab30.tar.bz2
aports-2584f7e32ac2faa4ffdb41258707409def05ab30.tar.xz
community/py3-ruamel.yaml: upgrade to 0.16.5
-rw-r--r--community/py3-ruamel.yaml/APKBUILD27
1 files changed, 10 insertions, 17 deletions
diff --git a/community/py3-ruamel.yaml/APKBUILD b/community/py3-ruamel.yaml/APKBUILD
index 4162c6bbba..79ad91ca0f 100644
--- a/community/py3-ruamel.yaml/APKBUILD
+++ b/community/py3-ruamel.yaml/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=py3-ruamel.yaml
-pkgver=0.15.91
-pkgrel=1
+pkgver=0.16.5
+pkgrel=0
pkgdesc="A YAML parser/emitter"
url="https://bitbucket.org/ruamel/yaml"
arch="all"
@@ -12,36 +12,29 @@ provides="py-ruamel=$pkgver-r$pkgrel py3-ruamel=$pkgver-r$pkgrel"
makedepends="python3-dev py3-setuptools"
checkdepends="py3-pytest py3-ruamel.std.pathlib"
source="$pkgname-$pkgver.tar.gz::https://bitbucket.org/ruamel/yaml/get/$pkgver.tar.gz"
-# 22286ce99d6552c658cb11d0a8a3c9b962ebe510 0.15.91
-builddir="$srcdir/ruamel-yaml-22286ce99d65"
+builddir="$srcdir/ruamel-yaml-ff02b83b8f91"
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir" \
--single-version-externally-managed
}
-check(){
- cd "$builddir"
- _plat_specifier="$(python3 <<-EOF
- from distutils.util import get_platform
- from sys import version_info
-
- print("{}-{}.{}".format(get_platform(), *version_info))
- EOF
- )"
- PYTHONPATH="build/lib.$_plat_specifier" python3 -m pytest \
+check() {
+ PYTHONPATH="$PWD/build/lib" python3 -m pytest \
--deselect=_test/test_issues.py::TestIssues::test_issue_82 \
--deselect=_test/test_issues.py::TestIssues::test_issue_220 \
--deselect=_test/test_issues.py::TestIssues::test_issue_238 \
--deselect=_test/test_yamlobject.py::test_monster \
--deselect=_test/test_yamlobject.py::test_qualified_name00 \
+ --deselect=_test/test_cyaml.py::test_load_cyaml \
+ --deselect=_test/test_cyaml.py::test_dump_cyaml \
+ --deselect=_test/test_cyaml.py::test_load_cyaml_1_2 \
+ --deselect=_test/test_cyaml.py::test_dump_cyaml_1_2 \
_test/test_*.py
}
-sha512sums="c9c9de649a40cb55953005a2fa991112c34a699409379c3c04d33f9f42efa7d0e43fb4c7e7f5caea1b6a86af4e0785925c541632bca88ab6b9c52969260b705a py3-ruamel.yaml-0.15.91.tar.gz"
+sha512sums="ce08ae50b9084d56c8e0f5a546cb3a23d4cdad643836aa60a44a995459d3d90057d14fa79493c36f415d7bc22936806d0b4f9b34f93192ac536526a314024c45 py3-ruamel.yaml-0.16.5.tar.gz"