aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-23 14:51:45 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-23 18:09:59 +0000
commit2cbe8d3bd9afa1ae23472c4b44d9688ccffdbc53 (patch)
tree6a9b7477710c2b3b20e07f16862a5e7aefba567d
parent01dbe7856721068d2ecd6af2659e0bd34787a371 (diff)
downloadaports-2cbe8d3bd9afa1ae23472c4b44d9688ccffdbc53.tar.bz2
aports-2cbe8d3bd9afa1ae23472c4b44d9688ccffdbc53.tar.xz
testing/py3-pyrsistent: new aport
for https://bugs.alpinelinux.org/issues/10282
-rw-r--r--testing/py3-pyrsistent/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-pyrsistent/APKBUILD b/testing/py3-pyrsistent/APKBUILD
new file mode 100644
index 0000000000..a601db5373
--- /dev/null
+++ b/testing/py3-pyrsistent/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-pyrsistent
+pkgver=0.14.11
+pkgrel=0
+pkgdesc="Persistent/Functional/Immutable data structures"
+url="https://github.com/tobgu/pyrsistent"
+arch="all"
+license="MIT"
+makedepends="py3-setuptools python3-dev"
+depends="py3-six"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tobgu/pyrsistent/archive/v${pkgver}.tar.gz"
+builddir="$srcdir/pyrsistent-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="8bfea52e15b1921ff9880a6d795cbbcdbee818ef5b95a2807e28269eba8ff578e07c39615e48eb47e867dd6f2bca5d395b7ae99ecd27424edaf6cbe6097b2e5d py3-pyrsistent-0.14.11.tar.gz"