aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-07-01 17:06:08 +0300
committerprspkt <prspkt@protonmail.com>2019-07-01 17:06:08 +0300
commit2d34dd9fa5434fe8039658f9864e5786a2cec005 (patch)
tree9ed70e37c13b4adc7fab0abf76ae2f2114376b4a
parent6c4be714cd87fce186735179a11065e98af74ac4 (diff)
downloadaports-2d34dd9fa5434fe8039658f9864e5786a2cec005.tar.bz2
aports-2d34dd9fa5434fe8039658f9864e5786a2cec005.tar.xz
testing/py3-jmespath: upgrade to 0.9.4
* Add checkdepends and run test suite.
-rw-r--r--testing/py3-jmespath/APKBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/testing/py3-jmespath/APKBUILD b/testing/py3-jmespath/APKBUILD
index e914591750..ae11c182e5 100644
--- a/testing/py3-jmespath/APKBUILD
+++ b/testing/py3-jmespath/APKBUILD
@@ -2,15 +2,15 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
pkgname=py3-jmespath
_pkgname=jmespath
-pkgver=0.9.3
-pkgrel=1
+pkgver=0.9.4
+pkgrel=0
pkgdesc="JMESPath is a query language for JSON"
url="https://jmespath.org"
arch="noarch"
license="MIT"
-options="!check"
depends="python3"
makedepends="py3-setuptools"
+checkdepends="py3-nose"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -21,8 +21,12 @@ build() {
python3 setup.py build
}
+check() {
+ nosetests -v
+}
+
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="eeab444df7a29c0bc64bd8064c942a5b02772d39d6d262dbef1d43ebaf7e4eb97c34fb1df3a47c6da011a632ec5f9b1ffe62ac51929e8d412368b907ebbb85a7 jmespath-0.9.3.tar.gz"
+sha512sums="173ec36708f93f72fece049b71846a226010c00498ab51e58bee26a09cc73cf96a062df215d3737eb266e689c2ecf7a2be95b009ed74ad122f6739d4379466c6 jmespath-0.9.4.tar.gz"