aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2020-03-11 13:55:49 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-03-11 11:11:02 -0300
commit81a73dad70151069829836b67cf0b2d808f9437f (patch)
tree74494561e411048a80320a33bdcbc82afb5e4151
parentc1696d67206c36d6aeaf8f0e618c3e9246668c42 (diff)
downloadaports-81a73dad70151069829836b67cf0b2d808f9437f.tar.bz2
aports-81a73dad70151069829836b67cf0b2d808f9437f.tar.xz
main/py-bluez: add missing py2-setuptools dependency
-rw-r--r--main/py-bluez/APKBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/main/py-bluez/APKBUILD b/main/py-bluez/APKBUILD
index 02ad3feeed..38df4b719c 100644
--- a/main/py-bluez/APKBUILD
+++ b/main/py-bluez/APKBUILD
@@ -3,31 +3,30 @@
pkgname=py-bluez
_pkgname=pybluez
pkgver=0.22
-pkgrel=3
+pkgrel=4
pkgdesc="Python API for the BlueZ bluetooth stack"
url="http://karulis.github.io/pybluez/"
arch="all"
-license="GPL-2.0"
-depends=""
-makedepends="python2-dev python3-dev py-setuptools bluez-dev"
+license="GPL-2.0-or-later"
+makedepends="python2-dev python3-dev py3-setuptools py2-setuptools bluez-dev"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="$pkgname-$pkgver.tar.gz::https://github.com/karulis/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
# Soure files are modified during build with 2to3 tool, so we cannot
# build it for both Python versions in the same location.
local python; for python in python2 python3; do
- cp -r "$builddir" "$builddir-$python" || return 1
+ cp -r "$builddir" "$builddir-$python"
done
}
build() {
local python; for python in python2 python3; do
cd "$builddir"-$python
- $python setup.py build || return 1
+ $python setup.py build
done
}