aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-10-17 13:07:22 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-24 18:56:34 +0000
commit94ea820aeefb9a91de0900071027ef9fd1653e38 (patch)
treefd41d25ad0cdf05bf24e0a1df79ef3288a3b263c
parentd1c404b2a1791c65ed67726c19880f087506ab8c (diff)
downloadaports-94ea820aeefb9a91de0900071027ef9fd1653e38.tar.bz2
aports-94ea820aeefb9a91de0900071027ef9fd1653e38.tar.xz
community/abiword: disable on s390x due to librsvg
Closes !509
-rw-r--r--community/abiword/APKBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/community/abiword/APKBUILD b/community/abiword/APKBUILD
index 52745ebe73..976affe98b 100644
--- a/community/abiword/APKBUILD
+++ b/community/abiword/APKBUILD
@@ -4,12 +4,12 @@ pkgver=3.0.2
pkgrel=4
pkgdesc="A fully-featured word processor"
url="http://www.abisource.com"
-arch="all"
+arch="all !s390x"
options="!check" # Test suite requires valgrind, etc
license="GPL-2.0-or-later"
makedepends="gtk+3.0-dev readline-dev libgsf-dev enchant-dev fribidi-dev wv-dev
popt-dev libjpeg-turbo-dev librsvg-dev bzip2-dev goffice-dev pcre-dev
- libxslt-dev"
+ libxslt-dev perl"
# openxml plugin
makedepends="$makedepends boost-dev"
@@ -29,13 +29,10 @@ for _i in $_plugins; do
subpackages="$subpackages $pkgname-plugin-$_i:_plugin"
done
-source="http://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz
+source="http://www.abisource.com/downloads/abiword/$pkgver/source/abiword-$pkgver.tar.gz
fix-black-drawing-regression.patch"
-builddir="$srcdir"/$pkgname-$pkgver
-
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -47,12 +44,11 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
_plugin() {
- local plugin="${subpkgname#${pkgname}-plugin-}"
+ local plugin="${subpkgname#$pkgname-plugin-}"
pkgdesc="Abiword $plugin plugin"
local dir="usr/lib/abiword-${pkgver%.*}/plugins"
mkdir -p "$subpkgdir"/$dir