aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 16:41:40 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 16:50:13 -0300
commit98285d3b22f3442523419e9c38b17467243cda68 (patch)
treeb9196b884243f40d5d18d86e596f777bbbdecd45
parentcfab83a2b7429996205da700e3da977f9d6fbe47 (diff)
downloadaports-98285d3b22f3442523419e9c38b17467243cda68.tar.bz2
aports-98285d3b22f3442523419e9c38b17467243cda68.tar.xz
community/py3-netifaces: drop py2
-rw-r--r--community/py3-netifaces/APKBUILD36
1 files changed, 8 insertions, 28 deletions
diff --git a/community/py3-netifaces/APKBUILD b/community/py3-netifaces/APKBUILD
index 767a311120..52bdb18418 100644
--- a/community/py3-netifaces/APKBUILD
+++ b/community/py3-netifaces/APKBUILD
@@ -1,50 +1,30 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-netifaces
+pkgname=py3-netifaces
_pkgname=netifaces
pkgver=0.10.9
-pkgrel=1
-pkgdesc="Portable module to access network interface information in Python"
+pkgrel=2
+pkgdesc="Portable module to access network interface information in Python3"
url="http://alastairs-place.net/netifaces/"
arch="all"
license="MIT"
-makedepends="python2-dev python3-dev py-setuptools linux-headers"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+makedepends="python3-dev py3-setuptools linux-headers"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-netifaces" # Backwards compatibility
+provides="py-netifaces=$pkgver-r$pkgrel" # Backwards compatibility
+
check() {
- cd "$builddir"
- python2 setup.py check
python3 setup.py check
}
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="8fc593de4d2cbda46a3e2430ede031360f1abfc64d47d00fbec09f3395fd83479bf29d97cb6834b1df06850c9ac2745c9344b6814f34be5975d4d5df98e05e87 netifaces-0.10.9.tar.gz"