aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-03-24 10:28:49 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-03-24 10:28:49 +0100
commite759028342f0e5889f840ad701828715e9cd8553 (patch)
treeae6fb2731c09ad6893a23844459706be7bd6407a
parent558a2bdde462ba3bad1740c03316ae07b412a002 (diff)
downloadaports-e759028342f0e5889f840ad701828715e9cd8553.tar.bz2
aports-e759028342f0e5889f840ad701828715e9cd8553.tar.xz
testing/xbps: fix build on aarch64
upstream PR: https://github.com/voidlinux/xbps/pull/236
-rw-r--r--testing/xbps/0001-configure-fix-vasprintf-test.patch32
-rw-r--r--testing/xbps/APKBUILD6
2 files changed, 36 insertions, 2 deletions
diff --git a/testing/xbps/0001-configure-fix-vasprintf-test.patch b/testing/xbps/0001-configure-fix-vasprintf-test.patch
new file mode 100644
index 0000000000..fcb99a8370
--- /dev/null
+++ b/testing/xbps/0001-configure-fix-vasprintf-test.patch
@@ -0,0 +1,32 @@
+From 58107bf76ad1310abf52d44d36fc165f2efd629d Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Fri, 24 Mar 2017 10:19:36 +0100
+Subject: [PATCH] configure: fix vasprintf test
+
+Fix the test for vasprintf function which failed with musl libc and
+fortify-headers on aarch64:
+
+_vasprintf.c:4:24: error: incompatible type for argument 3 of 'vasprintf'
+ vasprintf(NULL, NULL, NULL);
+ ^~~~
+---
+ configure | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure b/configure
+index 861a67d0..b043dab0 100755
+--- a/configure
++++ b/configure
+@@ -390,7 +390,8 @@ else
+ #define _GNU_SOURCE
+ #include <stdio.h>
+ int main(void) {
+- vasprintf(NULL, NULL, NULL);
++ va_list ap;
++ vasprintf(NULL, NULL, ap);
+ return 0;
+ }
+ EOF
+--
+2.12.1
+
diff --git a/testing/xbps/APKBUILD b/testing/xbps/APKBUILD
index ac5336cab5..f537b5807a 100644
--- a/testing/xbps/APKBUILD
+++ b/testing/xbps/APKBUILD
@@ -16,7 +16,8 @@ subpackages="$pkgname-dev $pkgname-doc
options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/voidlinux/$pkgname/archive/$pkgver.tar.gz
46744c412dca9ca2efc0df8ba1473ffd9145ddac.patch
- "
+ 0001-configure-fix-vasprintf-test.patch
+ "
builddir="$srcdir"/$pkgname-$pkgver
build() {
@@ -58,4 +59,5 @@ zshcomp() {
}
sha512sums="243dbef97bd94b05af1a79605f20050d00c6dfaffa8dbc56ea0b3b2d218a627fb45f157f9f82b6eb080f58a7445de9e7bf75d669f0be4caae262af5c5ac92262 xbps-0.51.tar.gz
-1e3e07152bbef6e7b10a462012c517beb2da207887ff1148c0b1509973efc520924236fd1e9ce9d5c0904cd403984caa52b5612f9037c1e24008711b68690221 46744c412dca9ca2efc0df8ba1473ffd9145ddac.patch"
+1e3e07152bbef6e7b10a462012c517beb2da207887ff1148c0b1509973efc520924236fd1e9ce9d5c0904cd403984caa52b5612f9037c1e24008711b68690221 46744c412dca9ca2efc0df8ba1473ffd9145ddac.patch
+2de97a2fc9041ee456e58798d302028d428770fde775c21564a8ae8a7ba57393d7ff5e64680f8c62456a377df7528249278197030708050bb776470570e28416 0001-configure-fix-vasprintf-test.patch"