aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-11-28 12:51:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-28 13:56:59 +0000
commit09443c3d0224ae169dffb03729b4513a6f77a1df (patch)
tree56cbffcc4b43198eaa10fbac564ff3fd2da2b8c1
parente474ab40ef04950140a4b4e12847ad617f427e4c (diff)
downloadaports-09443c3d0224ae169dffb03729b4513a6f77a1df.tar.bz2
aports-09443c3d0224ae169dffb03729b4513a6f77a1df.tar.xz
community/domoticz: fix build with python 3.8 and openzwave 1.6
-rw-r--r--community/domoticz/APKBUILD8
-rw-r--r--community/domoticz/DelayedLink.h-fix-build-with-python-3.8.patch64
2 files changed, 70 insertions, 2 deletions
diff --git a/community/domoticz/APKBUILD b/community/domoticz/APKBUILD
index d729b19a3f..6ab09382b6 100644
--- a/community/domoticz/APKBUILD
+++ b/community/domoticz/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=domoticz
pkgver=4.10717
-pkgrel=0
+pkgrel=1
pkgdesc="Open source Home Automation System"
url="http://www.domoticz.com/"
arch="all"
@@ -14,10 +14,12 @@ makedepends="cmake openssl-dev zlib-dev curl-dev boost-dev sqlite-dev
"
install="$pkgname.pre-install"
source="domoticz-$pkgver.tar.gz::https://github.com/domoticz/domoticz/archive/$pkgver.tar.gz
+ https://dev.alpinelinux.org/archive/domoticz/openzwave-1.6.patch
domoticz.confd
domoticz.initd
do-not-fail-if-git-missing.patch
boost-version.patch
+ DelayedLink.h-fix-build-with-python-3.8.patch
"
builddir="$srcdir/domoticz-$pkgver"
@@ -71,4 +73,6 @@ sha512sums="b7b3c702bf24be7bc314d261be5113b6ea598716b508443a18866391fbd7471764f1
724440da335f1e22c8dc181df62dac9ad2bcca98b39bff059de4be5901a93a0a8cb6864d92262092041d796ee7d3933f62cf337316d35a800bbb44f84a1709e0 domoticz.confd
3ddbd3848cce2247a52e4673307a078717d75cb3fea2937d9f2442d94dccd0efc63120f1b0324c7091ae158cd0ec4fd36334af43bb887d45ff4a93e6a96e9bd2 domoticz.initd
dc3e9207b984b042866538f6fe87d02c0b182e41f3fc8d747ee5368f148614474733fe11971a928dc0673dafdb0857f88bfc03823c364e013d8fdb515dc24403 do-not-fail-if-git-missing.patch
-aad8557eb68b4c98081ae43286f8f3dfade03b0d7f4dea71c2cc6ad3a652b1aa5ce401794ed11f47a8ec966056f6d2761258040b223ebc58b134ebb68e36b3d2 boost-version.patch"
+aad8557eb68b4c98081ae43286f8f3dfade03b0d7f4dea71c2cc6ad3a652b1aa5ce401794ed11f47a8ec966056f6d2761258040b223ebc58b134ebb68e36b3d2 boost-version.patch
+280cc5e3f9924255bfdf6980792a672820c5eb8f8e9e4bf7f6ee3ed1555edf267c9f2806cf265375c8f1b9804cc6f3ed8d3a507289e81fd1ebc8ff090ae3a65a DelayedLink.h-fix-build-with-python-3.8.patch
+be4ffd899b61bc3c108e04616514e64cf6b76ae7d8a26b5ddad1e45ff8ad53ca3c8cdc6e06efb1ff660634a44d6a28eca807222853ca36dd57baa0adafcab72a openzwave-1.6.patch"
diff --git a/community/domoticz/DelayedLink.h-fix-build-with-python-3.8.patch b/community/domoticz/DelayedLink.h-fix-build-with-python-3.8.patch
new file mode 100644
index 0000000000..c46c923636
--- /dev/null
+++ b/community/domoticz/DelayedLink.h-fix-build-with-python-3.8.patch
@@ -0,0 +1,64 @@
+From e9bd383ceb63db7cfe8a284014f0cdf8c2bfe4f0 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Fri, 1 Nov 2019 10:54:11 +0100
+Subject: [PATCH] DelayedLink.h: fix build with python 3.8
+
+Fix build with python 3.8 by copy/pasting the vim workaround from
+https://github.com/vim/vim/commit/13a1f3fb0c9d08bba6109fe2131c9524e6ba7e15
+
+Fix 3703
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ hardware/plugins/DelayedLink.h | 38 ++++++++++++++++++++++++++++++++++
+ 1 file changed, 38 insertions(+)
+
+diff --git a/hardware/plugins/DelayedLink.h b/hardware/plugins/DelayedLink.h
+index 4bf1973281..c90a7d8e69 100644
+--- a/hardware/plugins/DelayedLink.h
++++ b/hardware/plugins/DelayedLink.h
+@@ -14,6 +14,44 @@
+ #include <frameobject.h>
+ #include "../../main/Helper.h"
+
++#if PY_VERSION_HEX >= 0x030800f0
++static inline void
++py3__Py_DECREF(const char *filename, int lineno, PyObject *op)
++{
++ (void)filename; /* may be unused, shut up -Wunused-parameter */
++ (void)lineno; /* may be unused, shut up -Wunused-parameter */
++ _Py_DEC_REFTOTAL;
++ if (--op->ob_refcnt != 0)
++ {
++#ifdef Py_REF_DEBUG
++ if (op->ob_refcnt < 0)
++ {
++ _Py_NegativeRefcount(filename, lineno, op);
++ }
++#endif
++ }
++ else
++ {
++ _Py_Dealloc(op);
++ }
++}
++
++#undef Py_DECREF
++#define Py_DECREF(op) py3__Py_DECREF(__FILE__, __LINE__, _PyObject_CAST(op))
++
++static inline void
++py3__Py_XDECREF(PyObject *op)
++{
++ if (op != NULL)
++ {
++ Py_DECREF(op);
++ }
++}
++
++#undef Py_XDECREF
++#define Py_XDECREF(op) py3__Py_XDECREF(_PyObject_CAST(op))
++#endif
++
+ namespace Plugins {
+
+ #ifdef WIN32