aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-10-28 12:44:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-28 13:18:51 +0000
commit14753197c7491ae7b29288e8376d6f32bc74e095 (patch)
tree61566dabe157fb09f5fac75f07f31fc4c9e0d2dc
parentada41186f8709f57199c71158590a15df4d4cbe9 (diff)
downloadaports-14753197c7491ae7b29288e8376d6f32bc74e095.tar.bz2
aports-14753197c7491ae7b29288e8376d6f32bc74e095.tar.xz
testing/libqb: upgrade to 0.17.1 and fix build with musl
-rw-r--r--testing/libqb/APKBUILD (renamed from unmaintained/libqb/APKBUILD)17
-rw-r--r--testing/libqb/fix-headers.patch10
2 files changed, 21 insertions, 6 deletions
diff --git a/unmaintained/libqb/APKBUILD b/testing/libqb/APKBUILD
index 1642824efb..45c1090521 100644
--- a/unmaintained/libqb/APKBUILD
+++ b/testing/libqb/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libqb
-pkgver=0.16.0
-pkgrel=1
+pkgver=0.17.1
+pkgrel=0
pkgdesc="An IPC library for high performance servers"
url="https://github.com/clusterlabs/libqb/wiki"
arch="all"
@@ -11,7 +11,9 @@ depends_dev=""
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="https://fedorahosted.org/releases/q/u/quarterback/libqb-$pkgver.tar.xz"
+source="https://fedorahosted.org/releases/q/u/quarterback/libqb-$pkgver.tar.xz
+ fix-headers.patch
+ "
_builddir="$srcdir"/libqb-$pkgver
prepare() {
@@ -45,6 +47,9 @@ package() {
rm -f "$pkgdir"/usr/lib/*.la
}
-md5sums="51d2ca372c6b8151bf3544d93bcdc8db libqb-0.16.0.tar.xz"
-sha256sums="b8cda1efb33d0ce991aad552bbd71b59c16038c2095d139644a95b5b5ea17f48 libqb-0.16.0.tar.xz"
-sha512sums="5d8d6ee6e82717127d270cd1cbf0923592dd9ffda9a18f9b7c8f61b2f156d04d794ec6166ca0c2a536639fcf61c25354ececab1379b4a0c310252eebf5d68635 libqb-0.16.0.tar.xz"
+md5sums="5770b343baa4528f6fec90120ec55048 libqb-0.17.1.tar.xz
+1825f2c3b4405ccc5795fa2b6bbfce32 fix-headers.patch"
+sha256sums="7a2115f83bfe20eaa5f2e4ed235e8f2994235d3b87e3e5ca41ba47b320f12e29 libqb-0.17.1.tar.xz
+3be824e898e5b32d2a2869ebad3e930606b4bcee850f437e9bd9d126c28cbc4e fix-headers.patch"
+sha512sums="9705b291a61ca278fd0c9ab631af2cb844cdfc73b19501dd2e12eb162b37f0eded800860127a8a5c5c7c2a0e8db53e4780d3ab9697b099f4560a9a87aa8ec9ca libqb-0.17.1.tar.xz
+1b32bb6c82477b00434644b21e1ae450b9e5f5d3e4f6fd0428aafa117f7f129bfd94412544472affe0a273113222d238264da9bb874a25918fbeb2c4938e6d56 fix-headers.patch"
diff --git a/testing/libqb/fix-headers.patch b/testing/libqb/fix-headers.patch
new file mode 100644
index 0000000000..474f4c2fd5
--- /dev/null
+++ b/testing/libqb/fix-headers.patch
@@ -0,0 +1,10 @@
+--- ./include/qb/qbipcs.h.orig
++++ ./include/qb/qbipcs.h
+@@ -31,6 +31,7 @@
+
+ #include <stdlib.h>
+ #include <sys/uio.h>
++#include <sys/stat.h>
+ #include <qb/qbipc_common.h>
+ #include <qb/qbhdb.h>
+ #include <qb/qbloop.h>