aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorinfo@mobile-stream.com <info@mobile-stream.com>2018-11-26 22:05:43 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-30 08:28:22 +0000
commit2aca8d20a8e97a69f1883a09935cfb849891934e (patch)
treea8538b2d3a12dddafb13188c09d263e631293ed1
parent1d00829ecd91f5ab3b8727e5d610fc0384577014 (diff)
downloadaports-2aca8d20a8e97a69f1883a09935cfb849891934e.tar.bz2
aports-2aca8d20a8e97a69f1883a09935cfb849891934e.tar.xz
main/squid: fix build on mips{el} (-latomic)
While squid uses the proper autoconf logic to check if the -latomic is required for 64-bit atomics, its conftest.cpp fails to compile without -fpermissive thus yielding wrong result on 32-bit MIPS (which, until R6, lacks 64-bit atomics). Do not bother with configure{.ac} patches (too bulky), do not add -fpermissive to CXXFLAGS just to fix the conftest.cpp compilation (may affect too much) but simply pass -latomic preemptibly on mips{el}. As usual (no previous mips* apks exist, other architectures are unaffected), keep pkgrel intact. This commit should be removed when (if) upstream (or, really, autoconf) fixes the problem.
-rw-r--r--main/squid/APKBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/main/squid/APKBUILD b/main/squid/APKBUILD
index b7af679439..e4af2bde22 100644
--- a/main/squid/APKBUILD
+++ b/main/squid/APKBUILD
@@ -36,6 +36,7 @@ options="!check" # does not work. Error message is about "applet not found", so
build() {
cd "$builddir"
+ case "$CARCH" in mips|mipsel) export ac_cv_search___atomic_load_8=-latomic ;; esac
./configure \
--build=$CBUILD \
--host=$CHOST \