aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 14:16:12 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 14:21:35 +0000
commit30bce4f86f036808d552ba2cb35fa5cc7996e17f (patch)
tree58972c03d505a0f24ca79ffd520912cfde6e5146
parent69373ea27ae2a66b1c49f0e842ff4546e650a50b (diff)
downloadaports-30bce4f86f036808d552ba2cb35fa5cc7996e17f.tar.bz2
aports-30bce4f86f036808d552ba2cb35fa5cc7996e17f.tar.xz
community/py-mechanize: moved from testing
-rw-r--r--community/py-mechanize/APKBUILD (renamed from testing/py-mechanize/APKBUILD)13
1 files changed, 6 insertions, 7 deletions
diff --git a/testing/py-mechanize/APKBUILD b/community/py-mechanize/APKBUILD
index c7c661a271..e7e9576fe6 100644
--- a/testing/py-mechanize/APKBUILD
+++ b/community/py-mechanize/APKBUILD
@@ -9,21 +9,20 @@ url="http://wwwsearch.sourceforge.net/mechanize/"
arch="noarch"
license="BSD ZPL"
depends=
-depends_dev="python-dev py-setuptools"
-makedepends="$depends_dev"
+makedepends="python2-dev py-setuptools"
install=""
subpackages=""
source="http://wwwsearch.sourceforge.net/$_pkgname/src/$_pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/$_pkgname-$pkgver
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build || return 1
}
package() {
- cd "$_builddir"
- python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
install -Dm644 COPYING.txt ${pkgdir}/usr/share/licenses/custom/${pkgname}/COPYING.txt
}